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1. ЦЕЛЬ И ЗАДАЧИ ЛАБОРАТОРНЫХ РАБОТ 
Цель работ – познакомить студентов с методикой автоматизиро-

ванного проектирования силовых схем авиационных конструкций и вы-
работать практические навыки разработки ферм в среде MSC 
NASTRAN. 

Задачи лабораторных работ 
1. Знакомство с методикой силового анализа конструкций [1] для задач 

с плоской проектной областью. 
2. Освоение навыков разработки геометрических и конечно-

элементных моделей разного уровня. 
3. Поиск рациональной силовой схемы фермы для заданных граничных 

условий по методике проектирования [2]. 
 

2. ВАРИАНТЫ ЗАДАНИЙ 
Задана плоская геометрическая область, внутри которой может 

размещаться проектируемая конструкция. Известны размеры области, 
нагрузки, прикладываемые к конструкции и закрепления, представлен-
ные на рис. 1. Считается, что силы с различными индексами действуют 
разновременно. Используется материал со следующими характеристи-
ками: модуль упругости – 70000 МПа, коэффициент Пуассона – 0,3, до-
пускаемое напряжение – 300 МПа, плотность – 2700 кг/м3.   

Требуется найти рациональную силовую схему ферменной конст-
рукции для заданных граничных условий.  

 

 
 

Вариант 1 
 

Вариант 2 
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Вариант 3 

 

 
Вариант 4 

 

 
 

Вариант 5 

 

 
 

Вариант 6 

 
 

Вариант 7 

 
 
 

Вариант 8 
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Вариант 9 
 

Вариант 10 

 
Вариант 11 

 
 
 
 

Вариант 12 

 
 

Вариант 13 

 
Вариант 14 

 
Рис. 1. Варианты заданий 
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3. ТЕОРЕТИЧЕСКИЕ ОСНОВЫ 
АВТОМАТИЗИРОВАННОГО ПРОЕКТИРОВАНИЯ 

СИЛОВЫХ СХЕМ ПЛОСКИХ ФЕРМЕННЫХ КОНСТРУКЦИЙ 
 

Силовая схема конструкции (ССК) определяет тип силовых эле-
ментов, их количество, способы соединения между собой и расположе-
ние в пространстве. В работе [1] заложены теоретические основы авто-
матизированного проектирования силовых схем летательных аппаратов, 
в том числе ферменных конструкций. 

Для решения поставленной задачи используется следующий план 
отыскания рациональной ССК. 

1) В проектную геометрическую область вписывается контину-
альная упругая среда (заполнитель), содержащая внутри себя все воз-
можные силовые схемы конструкции. Такая модель конструкции на-
зывается континуальная модель. В качестве заполнителя для плоских 
конструкций используется мембранная изотропная пластина перемен-
ной толщины. 

2) Выполняется оптимизация распределения материала в контину-
альной модели и отыскивается теоретически оптимальная конструкция 
(ТОК), принимаемая за «идеал».   

Итерационный пересчёт толщин δ  в элементах пластины выполня-
ется по формуле поиска полнонапряжённой конструкции [1]: 

1, ,
[ ]

экв
ri

r i ri

σ
δ δ

σ+ = ⋅  

где r – номер итерации оптимизации, i – номер элемента, эквσ  – эквива-
лентное напряжение по принятой теории прочности, [ ]σ  – допус-
каемое напряжение.  
3) Анализируется силовая работа ТОК и с учётом конструктивных 

и технологических требований выбираются параметры рациональной 
ССК. Для этого применяется методика анализа передачи усилий в кон-
струкциях на основе потоков главных усилий (ПГУ) [1]. В каждом мем-
бранном элементе определяют главные напряжения и, умножая их на 
средние толщины элемента, получают потоки главных усилий. Изобра-
жают ПГУ с направлениями стрелок как у главных напряжений, а длину 
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стрелок назначают пропорционально величинам потоков усилий.  На 
данном этапе проектирования конструкции в зонах ТОК с одноосными 
потоками усилий располагаются стержневые элементы, в соответствии с 
направлениями векторов ПГУ. В зонах с двухосным распределением 
ПГУ рекомендуется использовать перекрёстную систему стержней. 

4)  Разрабатывается конечно-элементная модель (КЭМ), реали-
зующая рациональную структуру фермы. Оценивается весовая эффек-
тивность ССК с использованием силового фактора G, который характе-
ризует одновременно величину и протяжённость действия внутренних 
усилий в конструкции [4]. 

Силовой фактор определяется: 
• для фермы, состоящей из n элементов:  

1
,

n

i i
i

G N l
=

= ⋅∑  

где Ni – усилие в i-м стержне, li – длина стержня;    
•  для мембранных конструкций: 

1
,

n

i i
i

G R S
=

= ⋅∑  

где  R – эквивалентный поток усилий, S – площадь в плане элемента. 
Приведём некоторые свойства G, полезные для весовой оценки 

ферменных конструкций. 
• На величину G существенное влияние оказывает выбор пара-

метров ССК. 
• Для статически неопределимых конструкций G слабо зависит от 

распределения жёсткостей.  
• Для статически определимых ферм G вообще не зависит от со-

отношения жёсткостей силовых элементов.  
• G позволяет вычислить теоретически необходимый объём мате-

риала VТ для полнонапряжённой конструкции с определённой силовой 
схемой: 

[ ]
.Т

GV
σ

=  

Так, для полнонапряжённой фермы: 
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[ ]1 1
,

n ni
T i i i

i i

N
V l F l

σ= =
= ⋅ = ⋅∑ ∑  

где iF  – площадь поперечного сечения стержня. 

Отметим, что переход от ТОК к реальной конструкции осуществля-
ется на третьем этапе плана отыскания рациональной ССК с использо-
ванием эвристических приёмов и, следовательно, существует риск при-
нятия неверных технических решений. Для смягчения этого недостатка 
в статье [2] предложена методика проектирования ССК на основе по-
этапного замещения материала заполнителя в континуальной модели 
конструкционными элементами, реализующими принятые технические 
решения. Целенаправленное внедрение в континуальную модель конст-
рукционных элементов и оценка весовой эффективности их силовой ра-
боты позволяют своевременно выявить и скорректировать возможные 
неудачные технические решения. На рис. 2 представлена методика про-
ектирования ССК. 

 

 
 

Рис. 2. Блок-схема методики проектирования  ССК 
 

После выполнения всех этапов плана отыскания рациональной ССК 
в блоке 3 методики [2] создаётся КЭМ, реализующая выбранную ССК. 
Оценивается весовая эффективность конструкции и проверяется выпол-
нение функциональных требований, предъявляемых к ней. Затем к 
КЭМ, созданной в блоке 3, присоединяется заполнитель (блок 5) и 
управление процессом передаётся в блок 2. Анализ основных путей пе-
редачи сил и распределения материала в заполнителе после оптимиза-
ции позволяет разработать рациональные варианты усовершенствования 
ССК за счёт изменения расположения имеющихся силовых элементов 
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фермы или добавления дополнительных стержней. Процесс проектиро-
вания продолжается, пока очередные изменения в силовой схеме приво-
дят к снижению массы фермы и не исчерпано заданное число итераций 
(блок 4). 
 

4. ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ 

Для решения поставленной задачи по методике [2] выполняется 
цикл лабораторных работ с использованием системы NASTRAN [3] и 
специальных программ. На рис. 3 представлена последовательность 
применения специальных программ на этапах отыскания рациональной 
силовой схемы фермы. 

 

 

 
Рис. 3. Блок-схема применения специальных программ  

 
Сначала, на этапе 1, строится континуальная модель из мембран-

ных элементов, имеющих одно свойство (пластина постоянной толщи-
ны). Далее запускается программа Update_prop_3.bas, которая автома-
тически задаёт всем элементам уникальные свойства для последующей 
оптимизации распределения материала – получения пластины перемен-
ной толщины. 

На этапе 2 выполняется расчёт напряженно-деформированного со-
стояния пластины в NASTRAN. По найденным напряжениям в элемен-
тах пластины определяется распределение толщин мембранных элемен-
тов по формуле поиска полнонапряжённой конструкции с использова-
нием программы Optmembr.bas. Итерационное повторение процедуры 
«расчёт – оптимизация конструкции» позволяют отыскать ТОК.  

На основе анализа распределения материала в ТОК и картины ПГУ 
(этап 3) разрабатывается силовая схема фермы. Для этого используется 
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программа PGU1.bas, которая вычисляет векторы потоков главных уси-
лий и записывает их в файл выходных данных системы NASTRAN с 
номерами результатов 7426 и 7427. 

На этапе 4 проводится весовая оценка разработанной силовой схе-
мы ферменной конструкции. Для этого используется программа 
G_factor_V.bas, которая рассчитывает силовой фактор для ТОК и для 
модели, реализующей выбранную ССК. Если полученные значения си-
лового фактора отличаются более чем на 2%, то выполняется модифи-
кация ССК. Для этого в проектную область с фермой снова вписывается 
заполнитель (блок 5 на рис. 2). В результате получается комбинирован-
ная КЭМ, составленная из стержневых элементов фермы и  мембранных 
элементов континуальной модели. Для присвоения всем мембранным 
элементам уникальных свойств запускается программа 
Update_prop_3.bas. 

Далее выполняется оптимизация распределения материала в запол-
нителе с использованием программы Optmembr.bas. Интерпретация 
ПГУ в заполнителе «подскажет» технические решения, позволяющие 
улучшить ферменную конструкцию. 

Затем строится модель модифицированной фермы. Задаются уни-
кальные свойства стержневым элементам с использованием 
Update_prop_3.bas. Выполняется итерационная процедура «расчёт – 
оптимизация конструкции». С использованием G_factor_V.bas осуще-
ствляется весовая оценка модифицированной ССК.  

 
 

5. ОБЩИЕ УКАЗАНИЯ К  ВЫПОЛНЕНИЮ  
ЛАБОРАТОРНЫХ РАБОТ 

 
5.1. Пример проектирования 

На первой лабораторной работе преподаватель знакомит студентов 
с интерфейсом системы NASTRAN [3]. Демонстрируется решение при-
мера, представленного на рис. 4, при следующих значениях: A=1000 мм, 
С=100 мм, P=100 кН.  
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Рис. 4. Пример задания на проектирование 

 
Для описания последовательности действий в системе NASTRAN 

на примере решения этой задачи в дальнейшем изложении используют-
ся следующие условные обозначения: 

• названия команд выделяются полужирным шрифтом; 
• обозначение последовательности действий при выполнении ко-

манд приводится с использованием стрелки «→», например:  
File→Open; 

• занесение данных в текстовое поле диалогового окна обознача-
ется знаком =, например, ID=1.    
 

5.2. Определение теоретически оптимальной конструкции 

На второй лабораторной работе студентами для своих вариантов 
заданий в среде NASTRAN разрабатывается геометрическая модель 
конструкции, создаётся континуальная конечно-элементная модель 
(КЭМ-1), составленная из мембранных элементов. Оптимизация распре-
деления материала в этой модели с использованием программы 
Optmembr.bas позволяет определить ТОК. 

Порядок выполнения.  
1. Открытие нового файла: File→New.  
2. Создание геометрической модели: 
2.1. Создать прямоугольник: Geometry → Curve-Line → Rectangle 

→ нажать кнопку Method, установить Locate → ввод координат первого 
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угла  (0, 0, 0) → OK. В следующем диалоговом окне ввести координаты 
диагонально противоположного угла прямоугольника в мм (1000, 1000, 
0) → OK → Cancel.  

Установить изображение по центру, нажав клавиши Ctrl+A. 
2.2. Построить граничную поверхность: Geometry → Boundary  

Surface → From Curves → в окне выбрать линии, создающие замкнутые 
границы контура → OK → Cancel. 

2.3. Подготовить геометрическую модель к разбиению: Mesh → 
Mesh Control → Size along Curve → в окне размер сетки вдоль кривых 
указать число элементов на каждой стороне (рис. 5). 

Рекомендуется по возможности создавать конечные элементы 
квадратной или прямоугольной формы. 
 

 
Рис. 5. Задание параметров для генерации КЭМ-1  

 
3. Создание материала и свойств элементов: 
3.1. Создать характеристики материала: Model → Material → в окне 

определение изотропного материала задать название: Title=D16, модуль 
Юнга в МПа: E=70000, коэффициент Пуассона: nu=0.3, допускаемое 
напряжение в МПа: Limit stress (Tension)=300, плотность в кг/мм3: Mass 
Density=2.7E-6 → OK → Cancel.  

3.2. Создать свойства элементов №1: Model → Property → задать 
заголовок Title=membrane → выбрать материал <D16> в поле material 
→ нажать кнопку Elem/Property Type и установить тип элемента mem-
brane → OK → задать толщину в мм thickness = 1 → OK → Cancel.   
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4. Создание сетки конечных элементов с использованием автома-
тического генератора сеток: Mesh → Geometry → Surface → выбрать 
поверхность → OK → в новом окне выбрать свойство №1 → OK.   

5. Генерация уникальных свойств элементов: File → Program → 
Run Script → запустить программу Update_prop_3.bas → выбрать все 
элементы Select All → OK.  

6. Создание закреплений в узлах:  
6.1. Идентифицировать активный набор закреплений: Model → 

Constraint → Set → задать наименование набора закреплений Title → 
OK. 

6.2. Создать закрепления:  Model → Constraint → Nodal → вклю-
чить опцию Method → on Curve → выбрать узлы по ссылке на кривые 
для создания типа закрепления заделка → в секции DOF (степени сво-
боды): включить опции TX, TY, т.е. закрепить конструкцию по переме-
щениям X и Y → Cancel. Для создания закрепления в конкретном узле в 
опции Method выбрать ID. 

7. Задание нагрузок:  
7.1. Идентифицировать набор нагрузок: Model → Load → Set → за-

дать наименование набора нагрузок Title → OK.  
7.2. Создать нагрузки: Model → Load → Nodal → нажать на кнопку 

Method → установить ID → выбрать узлы, в которых приложены на-
грузки → в новом окне выбрать в списке слева Force (сила) → задать 
значение силы в Н → OK → Cancel.  

Для каждого случая нагружения фермы создаётся отдельный набор 
нагрузок. 

8. Расчёт конструкции: File → Analyze → нажать кнопку Manually 
Create Analysis Model → при наличии одного случая нагружения фермы 
заполнить поля таблицы Constraint и Loads → OK. При нескольких слу-
чаях нагружения воспользоваться кнопкой Loads → Select All → OK. 

Для просмотра результатов расчёта на панели команд нажать кноп-
ку Post Process → Post Data {} → в списке Output Set выбрать последний 
сет → во вкладке Output Vectors: поле Deformation=1. Total translation 
(полные перемещения узлов) → поле Contour=7433. Plate Bot VonMises 
Stress (эквивалентные по Мизесу напряжения) → OK.  

9. Оптимизация: File → Program → Run Script → запустить про-
грамму Optmembr.bas → нажать кнопку Method → выбрать Type → вы-
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брать мембранный тип элементов → OK → ввести Output Set → OK → 
получили новое распределение толщин в пластине.   

Для просмотра результатов оптимизации нажать кнопку Post Pro-
cess → Post Data {} → выбрать Output Set → Contour=100001. thickness. 
Для установки чёткого изображения (настройки резких границ) необхо-
димо выполнить: View → Select (F5) → снять галочку Render → OK. 

10. Последовательно повторить п. 8 и 9. Выполнить не менее 5 
циклов.    

По результатам очередной, i-ой итерации процесса оптимизации в 
папке C:\Users создаётся файл opt < i >. В этом файле содержатся отно-
шения действующих эквивалентных напряжений к допускаемому на-
пряжению для каждого элемента и максимальное значение по всей мо-
дели (Maximum stress ratio). Очевидно, что для полнонапряжённого 
проекта эта величина должна быть равна 1. Процесс  оптимизации мож-
но прекратить, когда коэффициент максимальных напряжений попадёт в 
диапазон от 0,95 до 1,05. Отметим, что папка  C:\Users является общей 
для всех решаемых задач в системе NASTRAN, поэтому пользователям 
периодически рекомендуется сохранять эту информацию.  

11. Сохранить КЭМ-1 в базе данных NASTRAN: File → Safe as → 
model_1.  

12. Запустить программу PGU1.bas. В окне выбора элементов ука-
зать группу элементов (можно нажать кнопку Select All), выбрать номер 
набора результатов, для которого далее будут построены ПГУ. 

13. Включить отображение ПГУ в графическом окне: View → Select  
(F5) → во вкладке Contour Style выбрать Vector, нажать кнопку De-
formed and Contour Data → Contour Vectors → в  окне Contour Vector 
Options (рис. 6) во вкладке Output Relative to задать местную систему 
координат элементов  Element Edge / Solid CSys or Nodal Output CSys, 
во вкладке Elemental Output Vectors установить для Vector 1 = 
7426..Plate Bot MajorPrn Stress, для Vector 2 = 7427..Plate Bot MinorPrn 
Stress. Нажав кнопку Palette, можно выбрать цвет изображения векто-
ров. 

Для настройки визуализации ПГУ на панели команд нажать кнопку 
Post Process → Post Options → More Options → выбрать вкладку Post 
Processing → выбрать в списке Contour Vector Style → в списке Vector 
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Style найти 0..Center, Dual Arrow (двойные стрелки в центре элемента) 
→ Apply → OK. 

 

 
Рис. 6. Настройка отображения ПГУ 

 
Для отключения отображения ПГУ выполнить: View → Select (F5) 

→ во вкладке Contour Style установить None - Model Only → OK.  
14.  Рассчитать силовой фактор ТОК: File → Program → Run Script 

→ запустить программу G_factor_V.bas → выбрать все элементы Select 
All → OK → ввести № результатов выходного набора → получили GТОК. 

В результате решения демонстрационного примера за 5 итераций 
оптимизации распределения материала найдена ТОК с  GТОК =2,59 ·108 
Н·мм.  
 

5.3. Разработка силовой схемы фермы 

В третьей лабораторной работе на основе анализа ТОК разраба-
тывается силовая схема фермы. Создаётся модель фермы (КЭМ-2), реа-
лизующая это техническое решение. 
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На рис. 7, а показано распределение толщин в ТОК для демонст-
рационного примера. Отметим, что сгустки материала пластины разме-
щены преимущественно в зонах А и Б. 

 

 
а) толщины, мм                                                 б)  ПГУ 

Рис. 7. Данные о ТОК, используемые для разработки ССК 
 

Распределение ПГУ (рис. 7,б) свидетельствует о преобладании в 
этих зонах одноосных потоков усилий, поэтому в соответствующих на-
правлениях целесообразно установить стержневые элементы. В качестве 
начального варианта ССК выберем двух стержневую ферму. Проверим 
весовую эффективность этого варианта ССК. 

Порядок выполнения. 
1. Сохраним model_1 (ТОК) как model_2.  
2. Удаляем все предыдущие результаты расчётов: Delete → Output 

→ Set → Select All → OK → OK. 
3. Удаляем все мембранные элементы: Delete → Model → Element 

→ нажать в окне выбора элементов для удаления Select All → OK. 
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Рис. 8. Узлы КЭМ-1 
 

4. Создаём свойство для стержневых элементов: Model → Property 
→ задать заголовок Title=Rod → выбрать material  <D16> → нажав на 
кнопку Elem/Property Type, установить тип элемента < Rod >  → OK → 
задать площадь поперечного сечения стержней в мм2: Area=100 → OK 
→ Cancel.  

5. Формируем ферменную конструкцию по уже существующим в 
модели узлам (рис. 8): Model → Element → в диалоговом окне выбрать 
свойство < Rod > → указать узлы, задающие начало и конец каждого 
создаваемого стержня → OK → Cancel.  

6. Удаляем все «лишние» узлы, не использованные в п. 5 для соз-
дания фермы: Delete → Model → Node → Select All → OK → OK. 

7. Проводим проверку на совпадающие узлы: Tools → Check → 
Coincident Nodes → Select All → во вкладке Options (Параметры) ста-
вим галочку Merge Coincident Entities (Слияние совпадающих объектов) 
→ OK.   

8. Создаём уникальные свойства для каждого стержневого элемен-
та: File → Program → Run Script → запустить программу 
Update_prop_3.bas → в окне выбора объектов Select All → OK. 

9. Расчёт: File→Analyze.  
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10.  Оптимизация фермы: File → Program → Run Script → выбрать 
программу Optmembr.bas → в окне выбора объектов нажать кнопку 
Method, выбрать Type → в выпадающем списке выбрать < Rod > → OK 
→ ввести № выходного набора → OK.    

  Просмотр результатов расчёта: 
Нажать на кнопку Post Process → Post Data {} → выбрать в списке 

Output Set → во вкладке Output Vectors: в поле Deformation: выбрать 1. 
Total translation → в поле Contour: выбрать 3183Rod Axial Stress (Осе-
вые напряжения в стержнях) → OK.  

На рис. 9 показаны напряжения в двухстержневой ферме. 
 

 
до оптимизации 

 
после  оптимизации 

Рис. 9. Осевые напряжения в стержнях КЭМ-2 
 

11.  Вычисление силового фактора фермы Gфермы: File → Program 
→ Run Script → запустить программу G_factor_V.bas → Select All → 
OK → ввести № выходного набора → OK.    

В результате найдена ферменная конструкция, состоящая из двух 
стержней, с силовым фактором Gфермы=2,82 ·108 Н·мм, превышающем 
значение для ТОК на 8,2 %, что свидетельствует о наличии резервов для 
снижения массы этой фермы.  
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5.4.  Модификация силовой схемы фермы 

На заключительной лабораторной работе в проектную область с 
найденной ферменной конструкцией вписывается заполнитель (конти-
нуальная модель). В комбинированной КЭМ-3, объединяющей ферму и 
континуальную модель, выполняется оптимизация распределения мате-
риала в заполнителе. Анализ распределения материала и ПГУ в запол-
нителе позволит модифицировать ССК, что найдёт отражение в модели 
модифицированной фермы (КЭМ-4).  

Порядок выполнения. 
1. Сохраняем model_2 как model_3. 
2. Создаём сетки мембранных конечных элементов: Mesh → Ge-

ometry → Surface → выбрать поверхность для генерации сетки → вы-
брать свойство {membrane} → OK.  

На рис. 10 представлена КЭМ-3, объединяющая двух стержневую 
ферму и континуальную модель. 

 
Рис. 10. КЭМ-3  

3. Задаём уникальные свойства мембранным элементам: File → 
Program → Run Script → запустить программу Update_prop_3.bas → 
нажать кнопку Method → выбрать Type → выбрать мембранный тип 
элементов → OK. 
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4. Удаляем все предыдущие результаты расчётов: Delete → Output 
→ Set → Select All → OK → OK. 

5. Расчёт:  File → Analyze. 
6. Оптимизация континуальной модели (только мембранных эле-

ментов): File → Program → Run Script → запустить программу 
Optmembr.bas → нажать кнопку Method → выбрать Type → установить 
мембранный тип силовых элементов → OK → указать число случаев 
нагружения → OK  →  № выходного набора → OK.  

Выполнить 10 – 20 циклов «расчёт – оптимизация».  
На рис. 11 показано распределение толщин и ПГУ в заполнителе 

после оптимизации.  
 
 

 
 а) толщины, мм    

б)  ПГУ 

Рис. 11. Данные о заполнителе в КЭМ-3 
 

В зоне А заполнителя наблюдаются сгустки материала. ПГУ в этой 
зоне располагаются по эллиптической траектории. Анализ результатов 
показывает, что в ферме с исходной ССК вместо стержня, положение 
которого не соответствует генеральному пути передачи усилий в зоне А 
заполнителя, целесообразно использовать два стержня, расположив их 
по эллиптической траектории. Для устранения «механизма» в месте 
стыка новых стержней необходимо добавить ещё один стержень, соеди-
няющий этот узел с нижним правым узлом опоры (рис. 12).         
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1. Сохраняем model_3 как model_4.  
2. Удаляем все мембранные элементы:  Delete → Model → Element 

→ нажать Select All → OK.  
3. Создаём ферменную конструкцию: Model → Element → в диа-

логовом окне выбрать свойство (rod) → нажать на кнопку Type и вы-
брать тип элемента Rod → OK → указать узлы для каждого создаваемо-
го стержня → OK.  

4. Удаляем все «лишние» узлы: Delete → Model → Node → Select 
All → OK → OK. 

5. Проводим проверку на совпадающие узлы: Tools → Check → 
Coincident Nodes → Select All → Merge  Coincident  Entities  → OK.  

6. Создание уникальных свойств стержневых элементов: File → 
Program → Run Script → запустить программу Update_prop_3.bas → 
нажать кнопку Method → выбрать Type → выбрать стержневой тип 
элементов → OK.  

7. Расчёт: File → Analyze.  
8. Оптимизация: File → Program → Run Script → запустить про-

грамму Optmembr.bas → нажать кнопку Method → выбрать Type → ус-
тановить стержневой тип элементов → OK → в новом диалоговом ок-
не указать число случаев нагружения → OK → ввести № выходного на-
бора → OK.     

9. Определение силового фактора: File → Program → Run Script 
→ запустить программу G_factor_V.bas → Select All → OK → ввести № 
выходного набора →  OK.  

На рис. 12 представлены напряжения в спроектированной четырех 
стержневой ферме. 

В результате этого занятия найдена ферменная конструкция, со-
стоящая из 4 стержней, с силовым фактором Gфермы=2,68·108 Н·мм. Зна-
чения силового фактора G для различных вариантов ССК представлены 
в табл. 1. 
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а) до оптимизации 

 
 

б) после оптимизации 

Рис. 12. Осевые напряжения в стержнях КЭМ-4   
 

Таблица 1 – Силовой фактор для ССК 

№ Конструкция Модель  G, *108 Н*мм  ∆G 
1 ТОК КЭМ-1 2,59 – 
2 Двух стержневая ферма КЭМ-2 2,82 8,2 % 
3 Четырех стержневая ферма  КЭМ-4 2,68 3,4 % 

 
 
 

6. СОДЕРЖАНИЕ ОТЧЁТА  
ПО ЛАБОРАТОРНЫМ РАБОТАМ 

В отчёте по циклу лабораторных работ должны содержаться сле-
дующие данные. 

1. Эскиз варианта задания с исходными данными. 
2. Данные по КЭМ-1. 
2.1 Картины эквивалентных напряжений и толщин в ТОК, пред-

ставленные численными значениями и линиями равных уровней.  
2.2 Картина ПГУ. 
2.3 Графики изменения коэффициента максимального напряжения и 

силового фактора по итерациям оптимизации заполнителя.  
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3. Осевые напряжения в стержнях фермы КЭМ-2. 
4. Данные по КЭМ-3.  
4.1 Картины эквивалентных напряжений и распределения материала 

в континуальном заполнителе.  
4.2 Картина ПГУ в континуальном заполнителе.      
5. Осевые напряжения в стержнях модифицированной фермы 

(КЭМ-4).   
6. Результаты вычисления силового фактора G для вариантов кон-

струкций.   
7. Анализ результатов и выводы по работе. 
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