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INTRODUCTION 

Many of the problems that researchers and engineers currently have to deal with do not lend 

themselves to an analytical solution or require huge problems for experimental implementation. 

Often the only possibility of express analysis of an engineering problem is computer mathematical 

modeling. Progress in the development of numerical methods has made it possible to significantly 

expand the range of problems available to analysis. In practice, the results obtained on the basis of 

these methods are used in virtually all fields of science and technology. 

In the analysis of constructions, the finite element method finds its most important 

application. In structural analysis, constructions are bridges, buildings, ship hulls, aircraft 

components, machine parts, pistons, tools, in other words, any engineering structures. 

The primary variables that are calculated during the construction analysis are the 

displacements. Further, based on the calculated displacements at the mesh nodes, other important 

parameters are determined, such as stresses, elastic or plastic deformation, etc. 

In this tutorial basic position of computer engineering analysis discussed in the examples 

solved using Ansys Mechanical that belongs to the class «heavy» systems and has advanced 

computing capabilities. 
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1 PREPARING FOR WORK AND LAUNCHING ANSYS 

 

1.1 Create new folder on the disk 

1) Start Menu – My Computer – Teacher specified disk – Right mouse button – 

Create – Folder 

2) Enter the name of the folder (name of the student). 

3) Close Menu. 

 

1.2 Launching Ansys 

1) Start Menu → Programs → Ansys 13.0 → Mechanical APDL Product Launcher. 

The menu is shown in Fig. 1.1. In the Working Directory column, specify the path to the 

previously created working folder. In the Job Name column, enter the name of the task (you can 

leave it by default). Click Run. 

 

Fig. 1.1. Ansys Mechanical Start menu 

 

2) After entering the interactive mode, the user's dialogue with the program is carried out 

through a multi-window "Graphical User Interface (GUI)" (Fig. 1.2). Briefly describe some of 

them. 
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Fig. 1.2. Graphical User Interface 

 

The top horizontal window 1 is the Utility Menu (UM), contains a set of often used 

commands for working with the model, such as saving and running models, displaying various 

model elements, working with coordinate planes, etc. 

Window 2 is the Main Menu (MM). It contains the main functions and stages of program 

execution, which are grouped into pop-up (dynamic) menus, which are dependent on the progress of 

the program. 

Window 3 is the Graphic window. It is an area for displaying such graphical information as 

a finite element model or graphs of analysis results. 

Window 4 is an Input window (Ansys input). The area for the command set and the output 

of messages in the Output Window. It is possible to access the list of previously entered 

commands. Commands duplicate actions that are conducted interactively. 

Window 5 allows you to control the position of geometry in space, zoom in and out of the 

model, rotate, etc. 
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2 STRUCTURAL ANALYSIS OF A BEAM WITH I-SECTION AND DISTRIBUTED 

LOADS 

 

We consider the classical problem of strength of materials about direct bending in one plane 

of an elastic multispan beam with piecewise constant bending stiffnesses. External force factors 

causing such a bend may be concentrated forces, moments and distributed loads with a piecewise 

linear change in intensity. 

 

2.1 Modeling of points and lines that define beam 

1) As an example, take beam with I-section (Fig. 2.1).   

 
Fig. 2.1.  Beam geometry 

 

This beam is located relative to the Cartesian coordinate system OXYZ so that the x-axis is 

directed along the axis of the beam (Fig. 2.1). The y- and z-axes are directed along the main axes of 

inertia of the section, and the zero coordinate is located at the left end of the beam. Direct transverse 

bending is carried out in the OXY plane. The characteristics of the cross-section (Fig. 2.2) are taken 

from GOST 19425-74, we select a beam with the profile number 20C: 
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Fig. 2.2. I-section of beam 

 

Tab. 2.1 – Initial data 

Beam 

parameters 

a, м q, kN/м M, kN∙м 
 

2 40 20 

Section 

parameters 

h, мм b, мм S, мм t 

200 100 7 11,4 

 

2) Create the start and end points defining the beam, as well as the point to which the 

load is applied: PrPr → Modeling → Create → Keypoints in Active CS. In the window that 

appears, enter the coordinates of the points: 

 x y z 

1 0 0 0 

2 2 0 0 

3 6 0 0 

 

3) Connect the resulting points in two segments: PrPr → Modeling → Create → 

Lines → Lines → Straight Line. Select points 1 and 2 → Apply, then 2 and 3 → OK . 
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2.2 Creating a finite element model  

1) Element type: PrPr → Element Type → Add/Edit/Delete. Select the element type 

Beam 188 → OK. You must specify the cross-section type: PrPr → Sections → Beam → 

Common Sections, select the I-section on the Sub-Type (Fig. 2.3)  

 
Fig. 2.3.  Beam Tool 

 

2) Material properties. PrPr → Material Props → Material Models. Set: modulus of 

elasticity ЕХ=2·1011 (Па); Density DENS = 7800 (kg/м3); Poisson's ratio PRXY=0,3; 

3) To orient the section of the beam in space, an orientation point is given. To orient the 

I-section along the Y-axis (Fig. 2.4), create a point 4 (0,1,0). 
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Fig. 2.4.  Orientation point location 

 

4) Specify the attributes of the created finite elements: PrPr → Meshing → Mesh 

Attributes → All Lines. In the column Pick Orientation Keypoint click Yes. Select point 4 as the 

orientation; 

 

Fig. 2.5.  Finite Element Attributes 

 

5) Specify the number of elements to be created on the lines. PrPr → Meshing  → Size 

Cnrtls → ManualSize → Lines. Select L1, NDIV=10 → Apply.  For L2 NDIV=20 
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6) Generate the finite element mesh: PrPr → Meshing → Mesh–Lines → Pick All. To 

display the finite elements of a beam type, you need to do the following: UM → PlotCtrls → Style 

→ Size and Shape → Display of Element → On 

 

Fig. 2.6.  Finite Element Beam Model 

 

2.3 Application of boundary conditions and loads 

1)  Simulate the hinged movable support (UY=UZ=0):  PrPr → Loads → Define 

Loads → Apply → Structural → Displacement → On Keypoints. Select point 1 – 

Apply. In the drop-down menu, select UY, then select UZ. Simulate a fixed-end: PrPr 

→ Loads → Define Loads → Apply → Structural → Displacement → On 

Keypoints. Select point 3 → All DOF → OK; 

2)  Simulate a linear load. A positive direction of linear load is the direction 

opposite the OY axis. Select the elements belonging to line 1: UM → Select → Entities 

→ Lines By Num/Pick → Line 1. Then, instead of Lines, select Elements, Attached 

to Lines, Reselect (only the selected line is used) → OK (Fig. 2.7). After clicking 

Plot Elements, you will see only the selected items; To apply the load: PrPr → 

Loads → Define Loads → Apply → Structural → Pressure → On Beam → Pick All, 

ValI=40000 → OK. Select now the hidden lines and elements: UМ → Select → Everything; 

Fig. 2.7 – Select 
elements 
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3) Apply the torque to the point. Positive is the moment directed counterclockwise: 

PrPr → Loads → Define Loads → Apply → Structural → Force/Moment →On Keypoints ,  

select point 2, set MZ=-20000 

 

2.4 Running on the calculation and analysis of results 

1) Run on calculation. Set the analysis type: MМ  → Solution → Analysis Type → New 

Analysis – Static. Run the solution: Solution → Solve → Current LS → OK. 

2) Display the deformation of the model relative to the OY axis (Figure 2.7), combined with 

an undeformed model: MM → General Postproc → Plot Results  → Contour Plot → Nodal 

Solu → DOF Solution → Y-Component of displacement, in the column Undisplaced shape key 

Deformed shape with undeformed model 

 

Fig. 2.8.  Деформация модели относительно оси OY 

 

3) Construct the curve of shearing forces Qy. The shearing force in Ansys has the opposite 

sign in comparison with the curve of shearing forces adopted. Using Help for the Beam188, we 

find the necessary commands for setting curves. To construct curve of shearing forces, enter on the 

command line as follows:  

ETABLE,QYI,SMISC,5 

ETABLE,QYJ,SMISC,18 

PLLS,QYI,QYJ 

To construct bending-moment curve, enter on the command line as follows: 

ETABLE,MZI,SMISC,2 
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ETABLE,MZJ,SMISC,15 

PLLS,MZI,MZJ 
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3 CALCULATION OF CONNECTED BARS LOADED WITH TEMPERATURE LOAD 

AND TENSILE FORCE. 

 

Consider a system of bars connected with each other by a beam: 

 
Fig. 3.1. System of bars 

 

Three bars of the same length are joined together by a beam, the central bar is loaded with a 

tensile force Q=10 kN. In addition, the bars are loaded with a temperature gradient. The two bars 

are made of copper, the central bar of steel. 

 

3.1 Geometry modeling 

1) Create start and end points defining the bars: MM → PreProcessor → Modeling → 

Create → Keypoints in Active CS. In the window that appears, enter the coordinates of the points: 

 x y z 

1 0 0 0 

2 0.04 0 0 

3 0.08 0 0 

4 0 0.08 0 

5 0.04 0.08 0 

6 0.08 0.08 0 

2)  Create line between points 1 and 4, 2 and 5, 3 and 6 (Fig. 3.2) 
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Fig. 3.2.  Construction of lines 

 

MM → PreProcessor → Modeling → Create → Lines → Lines → Straight Line. Select 

points 1 and 4, → Apply, then 2 and 5 → Apply, then 3 and 6  → OK. 

 

3.2 Finite element type and material properties 

1) Element type:  MM → Preprocessor → Element Type → Add/Edit/Delete. Select the 

element type Beam 188 → OK. Specify the type of cross section: MM → Preprocessor → 

Sections → Beam → Common Sections, select rectangular cross-section, setting B=H= 0,001 м; 

2) Set the material properties of copper and steel. MM →  Preprocessor → Material Props 

→ Material Models. For steel: Е=2·1011 (Pa); density 7800 (kg/m3); Poisson's ratio 0,3; coefficient 

of thermal expansion (Structural – Thermal Expansion – Secant Coefficient) α=11,85·10-6 1/0C. 

For copper: Е=1,2·1011 (Pa); density 8950 (kg/m3); Poisson's ratio 0,3; coefficient of thermal 

expansion α=16,8·10-6 1/0C; 

3) Specify the number of elements to be created on the lines. MM → PrPr → Meshing  → 

Size Cnrtls → ManualSize → Lines. For all lines, specify 10 elements; 

4) Generate a finite element mesh on copper bars: PrPr → Meshing → Mesh Attribute → 

Picked Lines. Select line 1 and 3, in the appeared window in the Material number column, set 2 

(copper material number), then select line 2 and set material number 1. Create the finite elements 

along the lines. To display the finite elements of a beam type, you need to do the following: UM → 

PlotCtrls → Style → Size and Shape → Display of Element → On; 



16 

 
Fig. 3.3. Finite Element Model 

 

3.3 Boundary conditions and load 

1) Connect the displacement of ends of the bars in the direction of the axis Y. MM → Prpr 

→ Coupling/Ceqn → Couple DOFs. Select nodes with numbers 2,13, 24, NSET set 1, Lab set 

UY; 

2) Fix the bars in the base to all degrees of freedom: PrPr → Loads → Define Loads → 

Apply → Structural → Displacement → On Nodes. Select nodes with numbers 1, 12, 23 → All 

DOF → OK; 

3) Apply a temperature load PrPr → Loads → Define Loads → Apply → Structural → 

Temperature → On Lines, set the temperature to 300 ° C for all lines; 

4) Apply a concentrated force in the direction of Y-axis to the end of steel bar: PrPr → 

Loads → Define Loads → Apply → Structural → Force/Moment, select nodes 24, set 

FY=1000. 

 

3.4 Running on the calculation and analysis of results 

1) Run on calculation. Set the analysis type: ММ → Solution → Analysis Type → New 

Analysis → Static. Run the solution Solution → Solve → Current LS → OK. 

2) Compare the stresses arising in the steel bar with stresses arising in the copper bar. Run 

on the command line the following macro: 

FINISH 

/POST1                                 

STEEL_N  = NODE (0.04,,,)           

COPPER_N = NODE (0.08,0,0)       
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STEEL_E = ENEARN (STEEL_N)    

COPPER_E = ENEARN (COPPER_N) 

ETABLE,STRS_ST,LS,1        

ETABLE,STRS_CO,LS,1    

*GET,STRSS_ST,ELEM,STEEL_E,ETAB,STRS_ST   

*GET,STRSS_CO,ELEM,COPPER_E,ETAB,STRS_CO 

 

Do the following calculation on your own: 

 
Fig. 3.4.  Cantilevered beam 

 

The cantilevered, unevenly heated beam with square section is loaded with axial force F. 

Determine the maximum tensile stresses in the fixed-end, as well as the axial displacement of the 

bar. 
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4 CREATING AREAS IN ANSYS 

 

4.1 Creating area by points 

1) Create points with coordinates: 

 x y z 

1 0 0 0 

2 1 0 0.1 

3 1 1 -0.1 

4 0 2 0.3 

2) Create area from the constructed points ММ → PrPr → Create → Areas → Arbitrary 

→ through KPs; 

3) Consistently in order of increasing numbers, select created points; 

4) Click ОК. 

 
Fig. 4.1. Creating area by points 

 

4.2 Delete area 

1) PrPr → Delete →  Areas only;  

2) Select area to be deleted; 

3) Click ОК. 

 

4.3 Creating area by lines 

1) UM →  Plot → Lines; 

2) MM → PrPr → Create → Areas →  Arbitrarys By lines; 

3) Select lines for the area to be created; 

4) Click ОК; 
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5) Delete all object data: UM → Files →  Clear & Start New → OK – yes. 

 

4.4 Creating area by skinning  

1) Create points with coordinates:  

 

 х у z 

1 -2.0 0.0 0.0 

2 -1.0 0.5 0.0 

3 0.0 0.8 0.0 

4 1.0 0.4 0.0 

5 2.0 0.0 0.0 

 

 
Fig 4.2.  First section 

 
2) Create a spline by points: ММ → PrPr → Сreate → Splines → Spline through KPs. 

3) Create points with coordinates: 

 

    х у z 

1 -2.0 -0.2 2.0 

2 -1.0 0.6 2.0 

3 0.0 0.8 2.0 

4 1.0 0.5 2.0 

5 2.0 -0.1 2.0 
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Fig 4.3.  Second section 

 

4) Create a spline by points. 

5) Create points with coordinates:  

  

 х у z 

1 -2.0 0.1 3.0 

2 -1.0 0.5 3.0 

3 0.0 0.7 3.0 

4 1.0 0.3 3.0 

5 2.0 0.1 3.0 

 

6) Create a spline by points. 

 
Fig 4.4 Third section 

 

7) Create area by splines MM → PrPr → Create → Areas →  Arbitrary → By Skinning. 

8) Consistently select three created splines. 

9) Click ОК. 
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Fig 4.5. Area by section 

 
10) Delete all object data. 

 

4.5 Creating area by rotating the line around an axis 

1) Create points with coordinates:  

 x y z 

1 -5 0 0 

2 10 0 0 

3 -5 2 0 

4 -2 2 0 

5 2 1 0 

6 6 3 0 

7 8 4 0 

8 10 4.5 0 

2) Create line between points KP3…KP4 и KP4…KP5. 

3) Create spline by points KP5…KP8. 

4) Display line numbers: 

UM → PlotCtrls → Numbering → LINE → ON → OK; 

UM → Plot →  LINE . 

5) Perform pairing of lines: 

1.  PrPr → Create → Line Fillet; 

2. Select L2 и L3; 

3.  Click ОК. 

4. Set the radius of the pairing RAD = 5. 

5. Click ОК. 
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6. UM → Plot → Replot. 

 
Fig. 4.6. Construction of fillets 

 

6) Create area by rotating lines: 

1. PrPr → Modeling → Operate → Extrude → Lines → About Axis. 

2. Click Pick All. 

3. Select KP1 and KP2, which determine the axis of rotation. 

4. Click ОК. 

5. Set ARC=360. 

6. Click ОК. 

 
Fig 4.7. Area of rotation 

 

7) Delete all object data. 
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4.6 Creating area as a circle segment or ring 

1) PrPr →  Modeling → Create → Areas → Circle →  Partial Annulus. 

2) Enter the coordinates of the circle center: wpx = 1; wpy = 1. 

3) Enter the inner radius of the segment Rad – 1 = 1(To create segment of circle must be 

specified Rad – 1 = 0). 

4) Enter the angle at which the radius is located relative to the x-axis, which defines the right 

boundary of the segment:  Theta –1 = 45. 

5) Enter the outer radius of the segment: Rad – 2 = 2. 

6) Enter the angle at which the radius is located relative to the x-axis, which defines the left 

boundary of the segment: Theta –2 = 180. 

7) Click ОК. 

8) Delete all object data. 

 

4.7 Creating area in the form of circle or ring 

1) PrPr →  Modeling → Create → Areas → Circle →  Partial Annulus. 

2) Enter the coordinates of the circle center: wpx = 1; wpy =1. 

3) Enter the inner radius of the circle Rad – 1 = 0. 

4) Enter the outer radius of the circle Rad – 2 = 2. 

5) Click ОК. 

6) Delete all object data. 
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5 MODELING OF SHELL FINITE ELEMENTS MESH  

 

5.1 Select finite element type: 

1) PrPr → Element type  → Add/Edit/Delete → Add; 

2) Select in the left window Shell; 

3) Select in the right window Elastic 4 node 181; 

4) Click ОК; 

5) Click Close. 

 

5.2 Set material properties and thickness of element: 

1)  PrPr → Material Props → Material Models. For steel: Е=2·1011 (Pa); density 7800 

(kg/m3); Poisson's ratio 0,3 

2) PrPr → Sections → Shell → Lay-up → Add/Edit.  Set: Thickness = 0,002 (m) 

3) Click ОК; 

 

5.3 Creating area in the form of rectangle: 

1) PrPr → Modeling → Create → Areas → Rectangle → By Dimensions; 

2) Set: х1=-2(м); х2=2(м); у1=-1(м); у2=1(м); 

3) Click ОК. 

 

5.4 Creating area in the form of circle with radius R = 0.5m and center located at 

the point with coordinates:  х=0; у=0: 

1) PrPr → Modeling → Create → Areas → Circle → Solid Circle; 

2) Subtract the area A2 from the area A1 by the operation Subtract.  PrPr → Modeling  → 

Operate → Booleans → Subtract → Areas. 

 

5.5 Set the created area attributes: 

1) PrPr → Meshing → MeshAttributes → Picked Areas. Select created area; 

2) Click ОК; 

3) Set: material number МАТ=1; element type TYPE = 1; coordinate system type ESYS=0;  

4) Click ОК. 

 

5.6 Set the edge size of the generated finite elements 

1) PrPr → Meshing → Size Cntrls → ManualSize → Lines → Picked Lines. Select all 

lines, set Size 0,001 м. 
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5.7 Generate arbitrary finite element mesh: 

1) PrPr → Meshing → Mesh → Areas → Free  → Pick All. 

 

 
Fig. 5.1.  Free mesh of finite elements 

 

5.8 Grinding of mesh  

PrPr → Modify Mesh → Elements. 

1) Mark in the Circle menu Refine mesh at elements; 

2) Move cursor to the center of hole, press left mouse button and, without releasing it, cover 

the circle with two layers of elements; 

3) Put labels in the Unpick and Single menus Refine mesh at elements; 

4) Cancel the cursor selection of randomly covered elements (leave only two layers of 

elements); 

 
Fig 5.2.  Grinding mesh 
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5) Click ОК. 

6) Set the grinding level LEVEL=2. 

7) Click ОК. 

 

5.9 Cleaning area from mesh 

1)  PrPr →Meshing → Clear → Areas. 

2) Select area on which the mesh of elements is cleaned. 

3) Click ОК. 

4) UM → Plot  → Areas. 

 

5.10 Generating an ordered mesh of shell finite elements 

1) Create point KP9 with coordinates: x=0; y=0; z=0. 

2) Create lines between points КР9 and КР4, КР9 and КР3, КР9 and КР2, КР9 and КР1. 

3) Subtract by operation Divide from area А3 of lines L11, L10, L9 and L12: 

4) PrPr → Operate → Divide → Areas by line: 

1. Select area А3; 

2. Click ОК; 

3. Select area L9, L10, L11 and L12;  

4. Click ОК. 

 
Fig. 5.3. Create intersecting lines 

 

5) Perform a pairwise summation of lines forming the circumference of the hole to reduce 

their number: 
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1. PrPr → Operate → Add  → Lines; 

2. Select lines L15 and L16; 

3. Click ОК; 

4. Click Apply; 

5. Select lines L18 and L19; 

6. Click ОК; 

7. Click Apply; 

8. Select lines L21 and L22; 

9. Click ОК; 

10. Select lines L24 and L23; 

11.  Click ОК. 

6) Specify the number of elements along lines PrPr → Size Cntrls → All Lines. 

1.Set:  NDIV=20. 

2.Click ОК.  

7) Generate an ordered finite element mesh PrPr → Mesh → Areas Mapped  → 3 or 4 

sided → Pick All. 

 
Fig.5.4.  Ordered finite element mesh 
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6 VOLUME MESH OF FINITE ELEMENTS 

 

Consider the calculation of the bladed disk of the compressor 

 
Fig. 6.1.  Volume model of bladed disk 

 

6.1 Creating a sectorial volume model of bladed disk 

1) Create points that define the shape of the disk: PrPr → Create → KeyPoints → in 

Active CS 

Номера точек X Y Z 

1 -0.025 0.09 0 

2 -0.025 0.115 0 

3 -0.004 0.155 0 

4 -0.004 0.23 0 

5 -0.007 0.230 0 

6 -0.007 0.255 0 

7 -0.004 0.255 0 

8 -0.004 0.29 0 

9 -0.014 0.29 0 

10 -0.014 0.3 0 

11 -0.03 0.3 0 

12 -0.03 0.325 0 

 

2) Since the bladed disk is symmetrical about the x-axis, reflect the second half of the points 

by the symmetry operation: PrPr → Modeling → Reflect → all → Y-Z plane; 
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3) Create two points with numbers 500 and 501 defining the axis of rotation of the disk with 

coordinates 500 (-0.01,0,0) , 501 (0.01,0,0); 

4) Create lines between points КР10 and КP11, KP11 and КР12, КР12 and КР24, КР24 and 

КР23, КР23 and КР22, КР20 and КР19, КР19 and КР18, КР18 and КР17, КР17 and КР16, КР16 

and КР15, КР15 and КР14, КР14 and КР13, КР13 and КР1; 

5) Create arcs between points КР10 and КР8 with center at point КР9 and radius 0,01, and 

between points КР20 and КР22 with center at point КР21 and radius 0,01; 

6) Create fillet radius of 0.02 between the following lines L1 and L2, L18 and L19, L2 L3, 

L18, L17. PrPr → Modeling → Create → Lines → Line Fillet; 

7) Create fillet radius of 0,003 between the following lines L6 and L4, L13 and L17. In Fig. 

6.2. shows the result of all the operations performed; 

 
Fig. 6.2. Disk contour 
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8) To create a finite element mesh, you must create 

additional lines. Create line between points К25 and К28, К26 and 

К27, К29 and К31, К30 and К32, К34 and К19, К33 and К35, К8 

and К20; 

9) Create an additional point К16 with coordinates (0, 

0.306, 0); 

10) Create arc by three points КР10, КР22, КР 16: PrPr 

→ Modeling → Create → Lines → Arcs → Thtough 3 KPs 

11) Create areas along the lines as shown in Fig. 6.3; 

12) Create a cylindrical coordinate system: 

1. Align the working coordinate system with the 

global: MM → Workplane → Align WP with 

Global Cartesian 

2. Rotate the working coordinate system by 900 

relative to the y-axis: MM → Workplane → Offset 

WP by Increments 

 

 
Fig. 6.3.  Creating areas 

3. Create a cylindrical coordinate system 11 that coincides with the working plane: MM 

→  Workplane → Local Coordinate Systems → Create Local CS → At WP origins 

13) Rotate areas by an angle of 30 relative to the axis of rotation disk: 

1. Go to the created cylindrical coordinate system: MM →  Workplane → Change 

Active CS to → Specified Coord Sys → 11 

2. Set the rotation of the areas by 30 relative to the z-axis: PrPr → Modeling → 

Move/Modify → Areas → Areas 

 
Fig. 6.4.  Area rotation menu 

 



31 

14) Create a sector of disk by operation of extrusion of areas: PrPr → Modeling → 

Operate → Extrude → About Axis. Select as the two points defining an axis of rotation points 

500 and 501. 

 
Fig. 6.5.  Bladed disk sector 

 

6.2 Cutting the groove in the rim of disc 

1) Set the working coordinate system on rim of disk as shown in Fig. 6.6. MM → 

WorkPlane → AlignWP with → Plane Normal to Line → L93 → Ratio Along Line=0,5. The 

coordinate system must be installed in the middle of the line 93, while the line will be normal to the 

XY plane; 

 
Fig. 6.6. Setting the working coordinate system 

 

2) Make working coordinate system of active: MM → WorkPlane → Change Active CS 

to → Working Plane; 
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3) Create 4 points that define the groove of disk: 

1 0.012 0 -0.0085 

2 0.012 0 0.0085 

3 0 0 -0.004132 

4 0 0 0.004132 

4) Create lines by points КР64 and КР65, КР65 and КР63, КР63 and КР62, КР62 and 

КР64; 

5) Add a fillet radius 0,002 м between lines L96 and L97, and between lines L98 and L97 

(Fig. 6.7); 

 
Fig. 6.7. Contour of groove of disc 

 

6) Create area along the contour lines of groove: PrPr → Modeling → Create → Areas → 

Arbitrary → By Lines, select lines with numbers in order L95, L96, L99, L97, L100, L98; 

7) Make the global coordinate system of active: MM → WorkPlane → Change Active CS 

to → Global Cartesian; 

8) Extrude in direction opposite to x-axis created area by 0.1 m: PrPr → Modeling → 

Operate → Extrude → Areas → By XYZ Offset; 

 
Fig. 6.8. Extrude areas menu 
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Fig. 6.9. Auxiliary volume for the groove cut-out 

 

9) By subtracting one volume from another, create a groove in the disk sector: PrPr → 

Modeling → Operate → Booleans → Subtract → Volumes. Select the disk volume first, then the 

secondary volume. 

 
Fig. 6.10. Groove in disc 

 

6.3 Preparing the model for mesh generation 

To create an ordered finite element mesh, split the disk rim into several volumes, each of 

which easily creates an ordered mesh. 

1) Create line from point 22 perpendicular to the line 10: PrPr → Modeling → Create 

→ Line → Lines → Normal to Line. In this case, the line 10 is divided into two lines, with a 

separating point КР64 (Fig. 6.11); 
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Fig.6.11.  Auxiliary line 

 

2) Cut the rim volume with the working plane (WorkPlane), for this you need to link it to the 

points КР64, КР22, КР57: MM → WorkPlane → Align WP with Keypoints;  

3) Delete the auxiliary line: PrPr → Delete → Line and Below → L93; 

4) Cut the rim volume with the working plane: PrPr → Operate → Booleans → Divide → 

Volu by WrkPlane; 

5) Proceed in the same action on the other part of disk rim, an auxiliary line is created from 

point КР10; 

 
Fig. 6.12. Splitting rim of disc 

 

6) Cut rim with the horizontal working plane. Combine the WorkPlane with the points 

КР82, КР83, КР68, then similarly to par. 4 cut three rim volumes by specifying them in the 

Boolean operation menu. Результат на Fig. 6.13; 
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Fig. 6.13. Final splitting of disk rim into separate volumes 

 

6.4 Generating finite element mesh 

1) Set material properties of disk PrPr → Material Props → Material Models. For steel: 

Е=2·1011 (Pa); density 7800 (kg/m3); Poisson's ratio 0,3. 

2) Set element type  

1.  PrPr → Element type  → Add/Edit/Delete → Add → Shell → 3D 4node 181 

2. PrPr → Element type  → Add/Edit/Delete → Add → Solid → Brick 8 Node 185 

3) Set the number of elements along the lines as shown in Fig. 6.14 and 6.15: PrPr → 

Meshing → Size Cntrls → Lines → Picked Lines. 

 
Fig. 6.14. Number of elements along the end face 

 
Fig. 6.15. Number of elements along the side surface 
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4) Set element type Shell 181: PrPr → Meshing → Mesh Attributes 

5) Create unordered mesh of finite elements on the lower end surface of A105 (Fig. 6.14): 

PrPr → Meshing → Mesh → Areas → Free. Based on this mesh will be created volume mesh. 

6) Set element type Solid 185, create the bottom half of the rim of the disk by extrusion 

(sweep): PrPr → Meshing → Mesh → Volume Sweep → Sweep. 

 
Fig. 6.16. Volume mesh on the bottom of disk rim  

 

7) Create ordered mesh on the remaining volumes of disk rim: PrPr → Meshing → Mesh 

→ Volumes → Mapped 4 to 6 sided 

 
Fig. 6.17. Volume mesh on rim of disk 

 

8) Specify the number of elements along edges of bladed disk as shown in Fig. 6.18. 
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Fig. 6.18. Bladed disk 

 

9) Starting from the top surface (A8), create a surface finite element mesh. For A6, specify 

type of mesh Free, for the rest type Mapped. The result in Fig. 6.19. 

 
Fig. 6.19. 2D mesh on the bladed disk 
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10) Create volume finite element mesh by extrusion: PrPr → Meshing → Mesh → 

Volume Sweep → Sweep. Specify volumes with numbers from 8 to 1; 

11) Remove the mesh from the areas: PrPr → Meshing → Clear → Areas → Pick all. 

 
Fig. 6.20. Finite-element disk sector model 

 

6.5 Boundary conditions and loads 

Since the for calculation is used sector model, it is necessary to impose cyclic symmetry 

conditions on opposite faces of the disk sector, connecting the displacements of the nodes of these 

faces in a cylindrical coordinate system in the direction of rotation. 

1) Select the areas that belong to the opposite faces of the sector: UM → Select → 

Entities → Areas → By NumPick; 



39 

 
Fig. 6.21. Selecting areas using the Polygon operation 

 

2) Select nodes that belong to these areas: UM → Select → Entities → Nodes → 

Attached to → Areas all → Reselect; 

 
Fig. 6.22. Select of nodes belonging to the opposite faces of the sector 

 

3) Connect the opposite nodes by the condition of cyclic symmetry: PrPr → Coupling/ 

Ceqn → Offset Nodes. Specify the coordinate system 11 (КСN), DY=60. Select all elements of 

model: UM → Select → Everything; 
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Fig. 6.23.  The cyclic symmetry condition menu  

 

4) Secure the disk sector. Select the areas A33 and A36, then the nodes belonging to 

these areas; 

 
Fig. 6.24. Surfaces for fixing the model 

 

5) Fixing model conveniently carried out in a cylindrical coordinate system. Go to the 

local cylindrical coordinate system 11: UM → WorkPlane → Change Active CS to → Specified 

Coord Sys → 11; 

6) Move the selected nodes to the local coordinate system: PrPr → Modeling → 

Move/Modify → Rotate Node CS → to Active CS; 

7) Secure the model in the axial (UZ) and radial (UY) directions: PrPr → Loads → 

Define Loads → Apply → Structural → Displacement → On Nodes; 

8) Select all model: MM → Select → Everything; 

9) Apply a centrifugal load 600 рад/с: PrPr → Loads → Define Loads → Apply → 

Structural → Inertia → Angular Velocity → Global → OmegX=600; 

10) Run on calculation: Solution → Analysis Type → New Analysis → Static. 

Solution → Solve → Curent LS; 
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11) Display the circumferential and radial stresses in the disk:  

1. Display the results in a cylindrical coordinate system: General Postproc → Options 

for Outp  - In the RSYS column set the Local system 

 
Fig. 6.25 Output of calculation results in a cylindrical coordinate system 

 

2. Output the circumferential stresses: General Postproc → Plot Results → Contour 

Plot → Nodal Solu → Stress – X-Component of stress 

3. Output the radial stresses: General Postproc → Plot Results → Contour Plot → 

Nodal Solu → Stress – Y-Component of stress 
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CONCLUSION 

 

The examples in this tutorial are the base level for students using Ansys Mechanical for 

structural analysis. The example of analysis simple designs shows the capabilities of the software 

package for creating finite element models, applying loads and calculating. The examples are 

created in such a way that allow us to study a large number of functions Ansys Mechanical, which 

will be necessary in the performance of course and project work in the senior years.  
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