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 В лабораторной работе № 2 по дисциплине «Методы обработки данных 

дистанционного зондирования» рассматриваются инструментарий и для углубленной 

обработки и анализа данных ДЗЗ, гео-привязки данных к территории и формирования 

покрытий на основе изображений полученных с различных космических аппаратов 

 Методические указания предназначены для магистров по направлению 010400.68 

―Прикладная математика и информатика‖, обучающихся по программе «Математические и 

компьютерные методы обработки изображений и геоинформатики». 
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Цель работы – изучение методов обработки и анализа космических снимков; 

получение навыков работы со специальным программным обеспечением; применение 

навыков обработки изображений к исследованию и анализу космических снимков. 

 

 

1.  ПОДГОТОВКА К ВЫПОЛНЕНИЮ ЛАБОРАТОРНОЙ РАБОТЫ 

1.1.  Инструкции к выполнению лабораторной работы. 

1. Ознакомьтесь с  руководством пользователя программного обеспечения 

обработки данных ДЗЗ.  

2. Поместите все примеры в отдельно созданную  директорию. 

3. Предварительно прочитайте задание и пример выполнения, затем повторите все 

действия, следуя инструкциям. 

4. Рекомендуется выполнять задания последовательно, так как знание предыдущих 

заданий позволят выполнить последующие. 



 4 

2. ВЫПОЛНЕНИЕ ЛАБОРАТОРНОЙ РАБОТЫ 

2.1.  Открытие данных ДДЗ.  

В программе реализован подход единого базиса (т.е. единой системы координат 

и пространственного разрешения), к которому приводятся все изображения, 

загруженные в программу. Данный принцип позволяет одновременно работать с 

изображениями, исходно лежащими в различных картографических проекциях и 

имеющих различное пространственное разрешение.  

Загрузка данных осуществляется командой File->Open главного меню или 

быстрой кнопкой  панели инструментов. Диалог Open состоит из двух закладок – 

Project Settings и Add Images.  

Перед загрузкой изображения необходимо указать систему координат и 

пространственного разрешения в закладке Project Settings диалога Open.  

Необходимо помнить, в случае автоматического определения картографической 

проекции и пространственного разрешения, данные параметры будут заданы в 

соответствии с первым загруженным в программу растровым изображением или 

векторным слоем, вне зависимости от автоматического определения картпроекции и 

разрешения у последующих подгружаемых слоев. Активизация автоматического 

режима происходит установкой флажка напротив опций Auto Pixel Size или Auto 

Projection в закладке Project Settings. При включенном флажке Auto Projection 

всегда задается проекция UTM WGS84 с автоматическим определением зоны 

привязанного изображения.  

Можно интерактивно задавать систему координат и пространственного 

разрешения как при открытии изображений, так и при работе с уже имеющимися 

данными в программе. В любом случае схема задания вручную системы координат и 

пространственного разрешения будет одинакова. Для этого надо снять флажки у 

опций Auto Pixel Size или Auto Projection в закладке Project Settings диалога Open. 

Далее в группе Pixel Size указать разрешение в метрах и (или) в группе Projection 

нажать на кнопку  и в появившемся диалоге Define Projection выбрать систему 

параметров проекции, после чего закрыть диалог кнопкой ОК. После внесенных 

изменений необходимо нажать на кнопку Apply в закладке Project Settings с 

последующим подтверждением выведенного окна-уведомления. При изменении 
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параметров проекции, системы координат или сфероида все загруженные растры и 

векторные слои также будут трансформированы.  

Включение опции Load As Raw Data в закладке Project Settings запрещает 

трансформацию изображения, и данные будут загружаться в пиксельной системе 

координат.  

Если подгружаемое в программу изображение имеет сопроводительные файлы-

привязки: ESRI World (файл системы ESRI ArcInfo / ArcView), Mapinfo TAB(файл 

системы Map_Info), ScanEx Geogrid (файл в формате Geogrid фирмы ScanEx), MET 

File (внутренний метафайл программы), то в закладке Add Images в группе 

Georeference from нужно активировать соответствующую опцию. Для упрощения 

работы с программой можно активизировать все опции, кроме ScanEx Geogrid, ее 

надо включать только при наличии соответствующего файла-привязки. 

2.1.1.  Открытие изображения с автоматическим определением 

проекции и разрешения. 

1. Вызовите диалог Open через главное меню File->Open или кнопкой  на панели 

инструментов. Диалог состоит из двух закладок – Project Settings и Add Images.  

2. В закладке Project Settings поставьте флажки у опций Auto Pixel Size и Auto 

Projection, затем перейдите в закладку Add Images.  

3. В закладке Add Images в группе File to Add при нажатии на кнопку  

появляется диалог загрузки изображений Import Image, откройте через него 

изображение Landsat_1.tif. Закройте диалог нажатием на кнопку OK.  

4. В группе Select Channel закладки Add Images открывается список каналов 

изображения. Курсором выделите все три канала или нажмите на кнопку Select 

All (рис.1).  

5. Оставшиеся опции закладки Add Images, кроме включенных трех опций ESRI 

World, Mapinfo TAB, MET File в группе Georeference from, должны быть не 

активны.  

6. Чтобы загрузить в программу указанные каналы, нажмите кнопку Add. Затем 

подтвердите кнопкой OK произведенную загрузку изображения в выведенном 

окне-уведомлении.  
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Рис. 1. Загрузка изображения с помощью диалога Open закладки Add Images. 

 

7. Закройте диалог Open кнопкой OK.  

8. Для закрытия каналов изображения откройте диалог Close Channels с помощью 

пункта меню File->Close Channels. В списке Channels курсором выделите все 

каналы или нажмите кнопку Select All. Выбранные каналы будут закрыты после 

нажатия на кнопку Close Selected. Диалог закрывается кнопкой Done (рис.2). 

 
Рис.2. Диалог Close Channels 
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2.2.  Инструменты навигации в рабочем окне программы. 

Вывод на дисплей загруженного изображения осуществляется через рабочее окно 

программы, открывается которое командой New RGB Window в меню Window. 

1.  Откройте изображение e:\SPOT\Fr1\I1.tif с автоматическим определением 

разрешения и проекции (см. «Открытие изображения с автоматическим 

определением проекции и разрешения»).  

2. Если в рабочем окне программы не визуализируется изображение, тогда 

необходимо последовательно выполнить или проверить выполнение следующих 

пунктов: 

  

Рис. 3. Диалог View Settings, 

закладка Adjust Colors 

 изображение необходимо настроить в 

диалоге View Settings, вызываемого через 

главное меню программы Display->View 

Settings. Диалог View Settings состоит из 

двух закладок Adjust Colors и Adjust 

Layers. Перейдите в закладку Adjust Colors 

и в группе Channels задайте каналы 

изображения в раскрывающихся меню 

полей: Red – 1_I1_ch1 (красный слот), 

Green – 2_I1_ch2 (зеленый слот), Blue –

3_I1_ch3 (голубой слот). В результате будет 

создана RGB – модель изображения. 

Произведите нормализацию гистограммы 

кнопкой Equalize , затем закройте диалог 

View Settings кнопкой ОК.  

 визуализируйте изображение целиком с 

помощью команды Tools->Fit to Window в 

главном меню или кнопкой  на панели 

инструментов.  

3. Откройте навигационное окно программы через команду главного меню Options-

>Navigator, чтобы определить месторасположение видимой части изображения в 

рабочем окне. В результате в верхнем левом углу активного рабочего окна 



 8 

появится окошко навигатора. Прямоугольник желтого цвета показывает контур 

рабочего окна на фоне всего загруженного изображения.  

4. Измените масштаб отображения посредством увеличительной лупы или 

уменьшительной лупы, вызываются которые командами Tools->Zoom In; Zoom 

Out или кнопками  и  на панели инструментов. Изменять масштаб 

изображения можно также «мышью» с колесиком для скроллинга. Проследите 

изменения в навигационном окне программы. 

 
Рис. 4. Навигационное окно в активном рабочем окне программы 

5. Вызовите инструмент Pan через команду Tools->Pan главного меню или кнопкой 

 и переместитесь по растровому полю. Передвигаться по изображению можно и 

при прокручивании колесика «мыши» с нажатой клавишей Shift- вертикальный 

скроллинг, с нажатой клавишей Ctrl – горизонтальный.  

6. Вернитесь к полноэкранному изображению, задействовав команду в меню Tools-

>Fit to Window или нажав на кнопку  на панели инструментов.    
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2.3.  Работа с гистограммой изображения. 

 
1. Откройте файл e:\SPOT\Fr1\I1.tif c автоматическим определением проекции и 

разрешения (см. «Открытие изображения с автоматическим определением 

проекции и разрешения»).  

2. За настройку параметров отображения в режиме RGB-модели и Grey отвечает 

диалог View Settings.  

Откройте диалог View Settings в меню Display->View Settings или кнопкой  на 

панели инструментов. Диалог состоит из двух закладок Adjust Colors и Adjust 

Layers.  

3. Перейдите в закладку Adjust Colors и в группе Channels задайте каналы 

изображения в раскрывающихся меню полей: Red – 1_I1_ch1 (красный слот), 

Green – 2_I1_ch2 (зеленый слот), Blue –3_I1_ch3 (голубой слот). В результате 

будет создана RGB – модель изображения в псевдоцвете, так как у загруженного 

снимка третий канал находится в ближней инфракрасной зоне спектра, второй и 

первый каналы - в красной и зеленой соответственно.  

4. Настройте изображение вручную, не используя кнопки Linear (линейное 

преобразование гистограммы) и STD (нормализация гистограммы). Для этого в 

группе Range горизонтальными движками слева и справа ограничьте график 

гистограммы в каждом слоте, переключаясь между ними. Отменить сделанные 

преобразования гистограммы изображения можно через кнопку None. 

5. Чтобы более точно определить границы графика гистограммы в каждом слоте, 

выберите один их них. В группе Histogram Boundaries задайте пороговые 

значения или интервал значений яркости Min и Max графика гистограммы, в 

данном случае, от 0 до 100. 

6. Для того чтобы улучшить цветопередачу изображения воспользуйтесь гамма-

коррекцией. В группе Gamma в закладке Adjust Colors включите флаг у опции 

RGB, чтобы изменения распространялись на все три слота RGB-модели 

изображения, в противном случае действие будет распространяться только на 

активный слот. Движком подберите величину гамма-коррекции в диапазоне от 0 

до 2. Для окончательного подтверждения выбранного коэффициента нажмите на 

кнопку Apply, расположенную под группой Color (Кнопка Apply подтверждает 
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подобранные Color и Range, независимо от дальнейших действий). 

7. Не закрывая диалога View Settings, нажмите комбинацию клавиш «Alt+1». В 

результате в  активном рабочем окне будет визуализирован первый канал 

изображения в режиме Grey. Кроме того, в диалоге View Settings в закладке 

Adjust Colors в слотах RGB-модели будет указан только канал 1_I1 _ch1. С 

помощью комбинации клавиш «Alt+№ канала» (комбинация применима только 

для первых 8 каналов изображения(й)) можно просмотреть яркостные особенности 

объектов снимка поканально. 

2.4.  Работа с векторными слоями. 

Программа позволяет импортировать и экспортировать векторные карты (слои), 

в форматах MapInfo (MIF/MID) и ESRI ArcInfo / ArcView (SHP). Для загрузки 

векторных слоев используется пункт меню Vector->Vector Layers Control или 

кнопка  на панели инструментов. 

При этом на экране появляется диалог управления загрузкой и представлением 

векторных слоев Vector Layers Control.  

В случае, когда при загрузке файла формата ESRI ArcInfo / ArcView с 

расширением *.shp нет сопроводительного PRJ- файла с определением системы 

координат, будет выведен диалог определения проекции Define Projection, в котором 

потребуется указать систему координат для данного файла.  

В случае, если векторный слой подгружается после загрузки растрового 

изображения или добавляется к векторным слоям в диалог Vector Layers Control, 

система координат рабочего проекта программы будет установлена в соответствии с 

системой координат первого загруженного векторного или растрового слоя. Для 

корректного отображения открытых в программе векторных слоев картографическая 

проекция должна быть у всех одинаковой или совпадать с системой координат 

рабочего проекта программы. 

2.4.1. Загрузка векторных слоев в программу. 

1. Откройте диалог управления загрузкой и представлением векторных слоев Vector 

Layers Control пунктом меню Vector->Vector Layers Control или кнопкой  на 

панели инструментов. В диалоге Vector Layers Control кнопкой Load откройте 
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диалог Open, в котором надо зайти в папку «Exercises», указать в выпадающем 

меню Files of type закладку ArcView Shape Files (*.SHP), затем выделить и 

загрузить файл CITIES.shp.  

2. Чтобы произвести какие-либо действия с векторным слоем CITIES.shp, выделите 

его и измените атрибутику с «-» на «+» элементов управления векторными слоями, 

задав:  

•  – разрешение  редактирования текущего слоя;  

•  – видимость текущего слоя;  

•  – возможность выделения объектов текущего слоя.  

3. Не закрывая диалог Vector Layers Control с загруженным векторным слоем 

CITIES.shp, перейдите к выполнению следующего упражнения (рис. 5).  

 
Рис. 5. Диалог Vector Layers Control с загруженным векторным слоем CITIES.shp 

2.4.2. Определение стиля отображения объектов в векторном слое. 

1. Подгрузите векторный слой CITIES.shp в диалог Vector Layers Control, 

открытый пунктом меню Vector->Vector Layers Control или кнопкой  на 

панели инструментов (см.«Загрузка векторных слоев в программу»).  

2. Задайте схему «Стиль по умолчанию». В диалоге Vector Layers Control кнопкой 

Legend вызовите диалог Symbology, в котором нажмите на кнопку Default Style с 

последующим нажатием на кнопку ОК. Закройте кнопкой Close диалог Vector 

Layers Control. Просмотрите полученный результат. 
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3. Задайте схему «Единый стиль отображения». Данная схема присваивает 

векторным объектам разных типов единый стиль отображения.  

3.1. Снова вызовите диалог Vector Layers Control с векторным слоем 

CITIES.shp, где кнопкой Legend запустите диалог Symbology. В диалоге 

Symbology с помощью кнопки Uniform Style откройте диалог Vector Display 

Properties.  

3.2. Так как в векторном слое CITIES.shp представлены точечные 

(символьные) объекты - города, то за вид их отображения отвечает группа Point 

Style в диалоге Vector Display Properties. В списке группы Point Style задается 

требуемый символьный шрифт, в поле Symbol задается порядковый номер 

символа в выбранном шрифте, в поле Size задается размер символа. Для 

изменения цвета символа необходимо нажать левой кнопкой мыши на 

прямоугольнике, расположенном справа, и в открывшемся диалоге Color указать 

требуемый цвет. Например, выберите в списке Point Style группу символов 

Wingdings, из них Symbol – 108, с размером Size – 12, красного цвета (рис.6). 

 

Рис. 6. Диалог Vector Display Properties 

3.3. Стили отображения других типов объектов остаются по умолчанию.  

Группа Region Style задает вид площадных объектов: цвет штриховки (цветной 

прямоугольник справа), вид штриховки заливки (Hatching) , а также вид границ 

заливки, их цвет, штриховку (Hatching), толщину (Width). Флаг Use 
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Background позволяет определить свойства фона площадных объектов при 

использовании штриховки, которая задается в списке Hatching.  

Группа Line Stile отвечает за визуализацию линейных объектов, их цвета (цветной 

прямоугольник справа), штриховки (Hatching), толщины (Width). 

3.4. Кнопкой OK подтвердите выбранные параметры с закрытием диалога 

Vector Display Properties. Закройте диалог Symbology кнопкой ОК, диалог 

Vector Layers Control - кнопкой Close. Просмотрите полученный результат.  

4. Задайте схему «Стиль по уникальному значению поля атрибутивной таблицы». 

4.1. Откройте диалог Vector Layers Control с векторным слоем CITIES.shp, 

в котором кнопкой Legend вызовите диалог Symbology.  

4.2. В диалоге Symbology включите переключатель Use Legend, чтобы 

активизировать группу Value Field. В списке Value Field задается поле 

атрибутивной таблицы векторного слоя CITIES.shp, которое будет 

отображаться в рабочем окне. Выберите поле COUNTRY векторного слоя 

CITIES.shp.  

Далее будет выведена таблица, в первом столбце таблицы, Field Value, 

прописываются уникальные значения выбранного поля, в данном поле – это названия 

городов. Во второй колонке таблицы, Legend, задается уникальная цветовая схема и 

стиль отображения каждого значения. Существуют три варианта определения 

цветовой схемы значений в диалоге Symbology, выберите наиболее подходящий, 

подтвердив выбор кнопкой OK:  

• Случайное распределение цветов, кнопка Random  

• Градиент от первой до последней записи, кнопка Gradient. Вначале необходимо 

задать начальный и конечный цвет, кликнув по цветовым прямоугольникам, 

расположенным под переключателем Use Legend, а затем нажать на кнопку 

Gradient диалога Symbology  

• Определение схемы для конкретного значения атрибутивной таблицы, для этого 

необходимо дважды кликнуть левой кнопкой мыши в требуемой ячейке колонки 

Legend, и определить стиль отображения при помощи появившегося диалога 

Vector Display Properties. 
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5. Кнопка OK закрывает диалог Symbology, подтверждая внесенные изменения. 

Кнопка Close закрывает диалог Vector Layers Control. Просмотрите полученный 

результат.  

2.4.3. Выбор отображения подписей объектов векторных слоев. 

Для отображения названия объектов векторного слоя необходимо включить 

режим их визуализации через команду меню Options�Show Names of Vector Objects. 

По умолчанию будут изображаться подписи объектов первого текстового поля 

атрибутивной таблицы загруженного векторного слоя.  

1. Загрузите векторный слой CITIES.shp в диалог Vector Layers Control.  

2. Для изменения поля подписей объектов откройте диалог Select Field to Display 

командой меню Vector->Select Field to Display.  

3. В диалоге Select Field to Display в списке Vector выводятся векторные слои, 

которые были предварительно загружены в диалог Vector Layers Control. 

Выберите слой CITIES.shp, затем в списке Field укажите одно из полей его 

атрибутивной таблицы, по которому будут созданы подписи, например, поле 

«NAME». В группе Color укажите цвет подписей, нажав левой клавишей мыши по 

цветному прямоугольнику справа (рис. 7). 

 
Рис.7. Диалог Select Field to Display 

4. Нажмите кнопку ОК для закрытия диалога. 

За корректное отображение подписей поля при изменении масштаба отвечает группа 

Sort Records. Если перед загрузкой данных векторного слоя в программу была 

предварительно выполнена сортировка в нисходящем порядке поля выводимых 

подписей, то кнопка Sort произведет сортировку подписей. В результате с 

уменьшением масштаба в первую очередь будут отображаться названия городов с 
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высокой численностью населения. При включении флага Descending Order 

включится сортировка в обратном порядке.  

5. Откройте диалог Vector Layers Control, выделите в нем векторный слой 

CITIES.shp и кнопкой Remove закройте его без сохранения изменений, 

внесенных в процессе работы. 

2.4.4. Создание нового векторного слоя. 

В программе существует возможность создания нового (пустого) векторного 

слоя в формате MapInfo MIF.  

1. Для создания нового векторного слоя откройте диалог Vector Layers Control 

командой меню Vector->Vector Layers Control, в котором кнопкой New MIF 

вызовите диалог Create New MIF File.  

2. В диалоге Create New MIF File в группе MIF File Name задайте директорию 

сохранения создаваемого файла кнопкой , а также его имя mask.mif.  

3. В диалоге Create New MIF File создайте три поля в векторном слое mask.mif:  

Поля атрибутивной таблицы векторного слоя задаются двумя столбцами:  

• Field Name отображает имя поля, для поля Name группы Field Properties 

• Field Type отображает тип поля, для списка Type группы Field Properties 

3.1. В группе Field Properties в строке Name назовите пустое поле 

«Name_object», задайте ему тип Char в выпадающем меню Type (текстовое). В 

Field Length укажите количество символов.  

3.2. Добавьте в таблицу кнопкой Add Field новое пустое поле, назовите его 

«Type_object». Тип поля Decimal (вещественное с указанием точности). Данный 

тип поля требует дополнительно указать число знаков после запятой в поле 

Decimals, задайте число знаков после запятой равное 0. В меню Field Length 

укажите количество символов 3. 
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Рис.8. Диалог Create New MIF File 

3.3.Создайте кнопкой Add Field еще одно поле с названием «Property» и типом 

поля Float (вещественное).  

3.4. В результате сформируется атрибутивная таблица векторного слоя mask.mif с 

тремя различными полями (рис.8). 

4. В группе Projection определите систему координат создаваемого слоя с помощью 

кнопки . В появившемся диалоге Define Projection выберите проекцию 

longitude/latitude с Datum (системой координат) WGS84 и сфероидом (Spheroid) 

WGS84, остальные параметры оставьте по умолчанию. Закройте диалог Define 

Projection кнопкой ОК.  

5. Кнопка OK закрывает диалог Create New MIF File, подтверждая внесенные 

изменения. Закройте диалог Vector Layers Control кнопкой Close. 

2.4.5. Создание и редактирование векторных объектов. 

 Все операции редактирования и создания объектов в векторном слое 

производятся в режиме «векторный редактор», для включения этого режима 

необходимо выполнить команду меню Vector->Vector Editor. В результате в 

активном рабочем окне появится панель инструментов векторного редактора 

(рис.9).Все инструменты данной панели продублированы в командах главного меню 

программы Vector, а так же в контекстном меню, появляющимся при клике правой 

кнопки мыши по полю рабочего окна. Закрыть панель инструментов векторного 

редактора можно кнопкой Close. 
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Рис.9. Панель инструментов векторного редактора 

В панели векторного редактора можно отменить одно неправильно сделанное 

действие кнопкой Undo .  

При создании объектов можно задавать стиль объектов в группе Object Style 

на панели инструментов векторного редактора. При этом необходимо помнить, что 

стиль отображения векторных объектов в векторном слое стоит по умолчанию. Для 

изменения стиля любого объекта, необходимо выделить его инструментом Select 

Object , затем выбрать инструмент Edit Object Properties  и, удерживая 

нажатой кнопку Shift, кликнуть левой кнопкой мыши по выделенному объекту. В 

результате будет открыт диалог Vector Display Properties. После выбора параметров 

визуализации векторного объекта закройте диалог Vector Display Properties кнопкой 

ОК, снимите выделение с объекта.  

На панели инструментов векторного редактора реализованы инструменты 

редактирования вершин и узлов, перед их активизацией предварительно выделите 

редактируемый векторный объект инструментом Select Object :  

 Для перемещения вершин и узлов предназначен инструмент Move Vertices . 

Выделите узел или вершину, захватите ее инструментом, нажав левую кнопку 

мыши, и, не отпуская кнопки мыши, переместите в требуемое место.  

 Для добавления новой вершины или узла используйте инструмент Add Vertices 

. Например, для добавления новой вершины необходимо кликнуть левой 

кнопкой мыши в требуемом месте на отрезке между двумя существующими 

вершинами. 

 Для удаления вершин и узлов используйте инструмент Delete Vertices . 

Для удаления вершины необходимо кликнуть по ней левой кнопкой мыши.  

Все функции дублируются при нажатии на выделенный объект правой кнопкой 

мыши. 

При создании объектов PolyLine и Region можно воспользоваться режимом 

объединения двух или более векторных примитивов. Для создания группы 

необходимо выделить векторный объект, кликнув по нему инструментом Select 
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Object , далее создать стандартным образом еще один векторный объект. После 

завершения его оцифровки, будет выведено сообщение о присоединения его к 

предыдущему объекту.  

Режим «свободного рисования» включается при цифровании объектов с 

нажатой клавишей Shift. 

В векторном редакторе предусмотрено несколько операторов для работы с объектами 

Region. Операторы:  

 Оператор Difference, инструмент , исключение одного полигона по контуру 

другого полигона.  

 Оператор Intersection, инструмент , исключение за пределами зоны 

пересечения полигонов.  

 Оператор Union, инструмент , объединение полигонов.  

 Оператор Split operation, инструмент , деление полигона другим 

полигоном.  

Для правильного использования операторов Difference, Intersection, Union, 

следует первоначально выделить инструментом Select Object  полигоны, затем 

выбрать оператор и кликнуть в полигон, по которому производится обработка. Чтобы 

вырезать один полигон из другого, выполните описанные ниже действия два раза. 

Выделите два интересующих полигона, затем инструментом Split operation  

нажмите внутри полигона, по которому производится обработка.  

Удаление выделенного векторного объекта кнопкой Delete Selected Objects  

либо нажатием на кнопку Del на клавиатуре. 

2.5. Улучшение пространственного разрешения (операция Image Fusion). 

1. Загрузите в программу изображения E:\SPOT\Fr1\I1.tif 20-метрового 

разрешения и E:\SPOT\Fr1\M1.tif 10-метрового разрешения с автоматическим 

определением проекции и разрешения (см. «Открытие изображения с автоматическим 

определением проекции и разрешения»). При открытии данных необходимо 

соблюсти последовательность их загрузки для корректного выполнения операции 
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улучшения пространственного разрешения: сначала – M1.tif с более высоким 

пространственным разрешением, затем – I1.tif.  

Проверьте пространственное разрешение рабочего проекта, которое должно 

равняться 6 метрам. Если оно не равняется указанному разрешению, то необходимо 

снять галочку Auto Pixel Size в закладке Project Settings, в поле Pixel Size поставить 

разрешение проекта равное 10 метрам и нажать на кнопку Apply. Разрешение 

проекта изменится после подтверждения сообщения «Projection changed».  

2. Визуализируйте загруженные изображения в режиме RGB, воспользовавшись 

диалогом View Setting (см.«Работа с гистограммой изображения»).  

3. Перед проведением операции необходимо произвести геометрическую 

коррекцию и совмещение снимков, в данном примере изображения отвечают 

предъявленным требованиям. 

4. Вызовите диалог задания операции Image Fusion через меню Edit->Image 

Fusion или кнопку на панели инструментов (рис.10).  

В данном преобразовании используется метод, основанный на методе главных 

компонент с многоуровневым вейвлет анализом. Комбинированность метода 

позволяет получить хороший результат при обработке данных нового 

поколения (Ikonos, Quickbird, OrbView, Landsat-7).  

5. В открывшемся диалоге в группе Panchromatic Image Channel выберите 

панхроматическое изображение M1 высокого пространственного разрешения.  

  
Рис.10. Панель Image Fusion  
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В списке Multispectral Image Channels выделите все каналы многозонального 

изображения I1.tif низкого пространственного разрешения.  

Параметр Mask определяет размер выходного изображения, в данном случае 

должно стоять значение «none», так как в операции будет задействована вся площадь 

изображений.  

Запустите процесс расчета предварительной модели улучшения пространственного 

разрешения кнопкой Fusion, после окончания которой появится новое рабочее окно 

«Fusion» с функциональной панелью инструментов операции Fusion.  

Кроме того, после расчета статистики для построения корректной модели 

улучшения пространственного разрешения, изображение разбивается на кластеры с 

сортировкой по качеству, параметром которого служит статистика максимальной 

дисперсии яркости в кластере. 

6. Чтобы отслеживать изменения параметров модели улучшения 

пространственного разрешения, отобразите через диалог View Settings изображение 

I1 в режиме RGB- модели для просмотра и оценки каждого сделанного изменения 

параметров в окне Fusion с последующим нажатием на кнопку Apply (рис.11).  

В окне Fusion, в группе PCA Settings подберите наиболее подходящие параметры 

выходной модели операции Image Fusion, изменяя значения в полях:  

Filter от 0 до 1, где указывается количество кластеров, в процентах  

Offset от 0 до 1, где задается начало первого используемого кластера, в процентах  

Отметьте изменения, происходящие с изображением, в случае включения опции 

Normalize, при которой значение каждого пикселя делится на стандартное 

отклонение. 
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Рис.11. Рабочее окно «Fusion» с функциональной панелью инструментов  

При наличии изображения с большим количеством деталей, как и в данном примере, 

лучше использовать статистику всех кластеров при создании модели, хотя большие 

значения дисперсии могут иметь и очень контрастные изображения с небольшим 

количеством деталей, тогда использование всех кластеров не позволит построить 

адекватную модель.  

7. После подбора значений параметров в группе PCA, попробуйте использовать 

многоуровневые вейвлет преобразования, это может улучшить цветопередачу 

изображения на выходе.  

Вейвлет-преобразования не участвуют в построении PCA модели, они участвуют 

только для декомпозиции изображения с высоким пространственным разрешением и 

главных компонент, что бы подменять не все изображение, а только 

высокочастотную часть пространственного «спектра». 

Флаг Use MRA включает режим вейвлет преобразований. Настройка параметров 

вейвлет преобразования происходит в группе Wavelet Settings, где: 

 MR Levels отвечают за число слоев высокочастотных вейвлет-коэффициентов, 
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которые заменяются в главных компонентах изображений с низким 

пространственным разрешением, диапазон значений варьируется от 1 до 6.  

 MR planes задаются числом главных компонент изображений низкого 

пространственного разрешения (т.е. это число выбранных каналов 

мультиспектрального изображения для Image Fusion), которые подменяются 

главными компонентами изображения с высоким пространственным 

разрешением. 

 Smooth Output – включает использование ресемплируюшего фильтра Linear 

при синтезировании результирующего изображения.  

8. После подбора значений параметров кнопкой Compute вызовите диалог Select 

Channel, позволяющий выбрать синтезируемые каналы, и подтвердите в нем кнопкой 

ОК заданную предварительную модель улучшения пространственного разрешения 

для расчета. Опцию Histogram Matching оставьте неактивной. В результате будут 

созданы и загружены в программу новые растровые каналы с добавленным 

окончанием «_fus».  

2.6. Создание зеленого и голубого каналов. 

Данную опцию можно использовать для синтеза зеленого или голубого каналов при 

наличии только ближнего инфракрасного и красного каналов. 

1. Обязательное условие – наличие ближнего ИК и красного каналов снимка. 

Воспользуйтесь результатами выполненного упражнения «Улучшение 

пространственного разрешения (операция Image Fusion)». 

2. Зайдите в главное меню программы: Edit – Spectral Transform – Natural Color2 

(рис.12). Появится диалоговое окно заданной операции Spectral Transform\Natural 

Color2, где следует:  

• выбрать из списка каждого слота NIR; Red; Green соответствующий 

монохроматический канал изображения.  

• определить ресемплирующий фильтр, например, Hermit.  

• сделать неактивными опции Ignore Vector Mask, Ignore NODATA Value, Raw 

Data 

• определить площадь обработки изображения каналов через группу Domain, 

выберите общую, Union. 
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Рис.12. Диалог Spectral Transform/Natural Color2 

Если требуется задействовать только фрагмент изображения, заданного заранее 

Vector Mask или Select region, то надо активизировать группу Mask, убрав флаг 

напротив опции Raw Data. Для запуска операции нажмите кнопку OK. 

4. В окне View Settings (вызвать которое можно через главное меню программы 

Display – View Settings или кнопкой  на панели инструментов), в закладке Adjust 

Colors при выборе в списке каналов слота появятся два рассчитанных канала, 

зеленый и голубой, названия которых «nc2_green» и «nc2_blue», задайте синтез 

R:G:B изображения в естественных тонах 

5. Для вычисления только зеленого канала используется опция: Edit – Spectral 

Transform – Natural Color1. В открывшемся диалоге укажите следующие каналы 

напротив слота: NIR - ближний ИК канал, GREEN – красный канал. Выбор 

остальных параметров такой же, как и в диалоге Spectral Transform Natural Color2. 

На выходе получается канал - «synth_green». 

Можно изменить или создать свой алгоритм или макрос по вычислению 

зеленого или голубого канала можно на основе алгоритмов, рассмотренных 

выше. Например, подобрать свои коэффициенты при вычислении зеленого и 

голубого каналов через диалог Combine Channels с выбором из 

раскрывающегося меню Templates закладки «Spectral Transform\Natural 

Colors 2» и указанием в группе Combining Rule коэффициентов вычисляемого 

выражения. 
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2.7. Геометрическая коррекция. 

Геометрическая коррекция – это обеспечение с максимальной точностью 

перехода от внутренней системы координат снимка к выбранной картографической 

системе координат.  

Систематическая геометрическая коррекция – коррекция систематических 

ошибок изображений с использованием математической модели, описывающей 

пространственное положение спутника и камеры в момент съемки. Входными 

параметрами для математической модели являются положение спутника, углы 

ориентации спутника и камеры, а так же параметры камеры (такие как время 

сканирования одной строки, фокусное расстояние, параметры дисторсии объектива).  

Кроме того, систематическая коррекция может выполняться по 

предрассчитанной сетке координат. Многие операторы съемочных систем включают 

совместно с углами ориентации и рассчитанную сетку координат. Такие сетки 

сопровождают данные TERRA\AQUA MODIS, TERRA ASTER, RADARSAT-1 (в 

формате CEOS), также такая сетка может быть экспортирована программой Scan 

Magic.  

В программе систематическая коррекция производится в момент загрузки 

данных в программу и не требует выполнения каких-либо дополнительных действий, 

кроме определения требуемой системы координат (картографической проекции).  

Для проведения геометрической коррекции необходимо использовать 

дополнительную информацию: 

 опорные точки, описывающих переход из системы координат снимка к 

выбранной картографической системе координат. Для лучшего результата 

трансформации опорные точки должны быть нанесены равномерно по снимку.  

 цифровые модели рельефа (DEM). Используя ЦМР и информацию о 

координатах, хранящуюся в опорных точках, можно выполнить 

геометрическую коррекцию за рельеф территории на снимке.  

В программе реализовано несколько математических моделей, позволяющих 

увеличить точность геопривязки с использованием опорных точек, а также с 

возможностью произведения геометрической коррекции с учетом рельефа местности 

по ЦМР:  



 25 

 Satellite Orbital Modelling – итерационная уточняющая модель, позволяет 

используя опорные точки, уточнить углы ориентации спутника и камеры, а 

также может быть использована при проведении ортокоррекции.  

 Polynomial Transformation – полиномиальная модель, данный вид 

преобразований может быть использован в случае, если информация об углах 

ориентации спутника и камеры отсутствует. В программе существует 

возможность использования как классической, так и рациональной 

полиномиальной модели. При использовании данного класса преобразований 

есть возможность применять ЦМР.  

 Local (Hierarchical) Transformation – данная модель может быть использована 

для исправления локальных ошибок, например коррекции обрывов и оврагов.  

2.7.1. Установка опорных точек. 

Перед тем как производить операцию, необходимо в рабочем окне программы 

настроить параметры отображения растра, который будет трансформироваться. В 

случае привязки его к векторной карте, надо загрузить векторную карту. В случае 

привязки растра к растру, надо создать второе рабочее окно и настроить в нем 

параметры отображения второго растра, эталонного изображения, с которого берутся 

опорные точки.  

В этом упражнении привязка осуществляется растр к растру. 

1. Откройте I1.tif привязываемое (трансформируемое) изображение с 

автоматическим определением проекции и разрешения (см. «Открытие 

изображения с автоматическим определением проекции и разрешения»). После 

чего загрузите в рабочую сессию ортотрансформированное изображение I2.tif.  

2. Задайте два рабочих окна через опцию главногоменю Window->New RGB 

Window. Откройте и синхронизируйте их через командыменю Window->Tile 

Vertical и Window->Synchronize Windows.  

3. В каждом окне настройте параметры отображение в режиме RGB одного из 

растров с помощью диалога View Setting (см.«Работа с гистограммой 

изображения»).  

4. Перед началом установки опорных точек GCP удостоверьтесь, что пункт меню 

Options->Show GCP включен. Действие данной команды распространяется на все 

открытые рабочие окна.  
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5. Сделайте активным рабочее окно изображения I1.tif, и откройте в нем панель 

инструментов в режиме установки и редактирования опорных точек GCP 

командой меню Transformation->Set GCP или кнопкой  на панели 

инструментов (рис.13).  

 
Рис.13. Панель инструментов установки и редактирования опорных точек GCP 

6. Найдите на трансформируемом растре IRS_LISS2.hdf характерную точку, 

например, место слияния рек, и соответствующую ей точку на эталоне 

Ortolandsat_kavkaz.tif. Активизируйте инструмент установки опорных точек , 

затем на трансформируемом растре установите курсор на найденную точку, 

кликните по ней левой кнопкой мыши, переместите курсор в соответствующую 

точку на эталоне, кликните по ней левой кнопкой мыши. Опорная точка будет 

установлена и отобразится в виде вектора тика. Стрелочка которого «>» покажет 

направление смещения трансформируемого растра. 

7. В панели инструментов установки и редактирования опорных точек выводятся 

прямоугольные координаты установленной опорной точки трансформируемого 

растра в полях From X, From Y и эталонного изображения в полях To X, To Y. 

Можно посмотреть координаты точек в географической системе координат, 

включив опцию Use Long/Lat.  

 
Рис.14. Установка опорной точки GCP на трансформируемом и эталонном растрах. 
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В поле Elevation для каждой установленной опорной точки можно задать ее 

высотную отметку, если в дальнейшем посредством использования опорных точек 

будет производиться ортокоррекция. 

В программе реализованы следующие операции по установке и редактированию 

опорных точек:  

Выделение точек.  

Выделите выбранную опорную точку с помощью инструмента Select GCP, 

вызывается который командой меню Transformation->Select GCP или кнопкой  

панели инструментов. Кликнете мышкой по опорной точке, при этом стрелочка, 

указывающая направление будет перекрашена в желтый цвет «>».  

Для выделения всех опорных точек вызовите команду Transformation->Select All 

GCP.  

Для снятия выделения необходимо просто кликнуть на экране левой кнопкой мыши. 

Редактирование точек.  

Если вы неправильно поставили точку, то выделите ее предварительно инструментом 

Select GCP и инструментом Edit GCP произведите редактирование, вызов которого 

осуществляется командой меню Transformation->Edit GCP или кнопкой .  

Удаление точек.  

Все инструменты вызываются одноименными командами из меню Transformation:  

 инструмент Transformation->Delete All GCP удаляет все установленные 

опорные точки.  

 инструмент Transformation->Delete Selected GCP удаляет выделенные 

опорные точки.  

 инструмент Transformation->Delete Last GCP удаляет последнюю 

установленную опорную точку.  

8. Наберите определенное количество опорных точек инструментом Set GCP, кнопка 

 на панели инструментов, не забывая, что для получения корректного 

результата трансформации изображения опорные точки должны быть нанесены 

равномерно, в центре и по краям снимка.  
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Рис.15. Установленные опорные точки на снимке. 

Просмотреть все опорные точки в виде списка можно в диалоге List of GCPs, 

открывается который командой меню Transformation->List of GCPs. В диалоге List 

of GCPs можно выделить нужные опорные точки, изменив в столбце Sel атрибут No 

на Yes.  

9. Установленные опорные точки сохраните в файл с расширением .tic и названием 

«Spot», для этого необходимо выполнить команду меню File->Save GCP.  

Для загрузки опорных точек из файла необходимо выполнить команду File->Load 

GCP главного меню. Файл с сохраненными опорными точками корректно откроется 

лишь в той проекции, в которой будет сохранен. 

2.7.2. Итерационная уточняющая модель. 

Систематическая коррекция в программе проводится с помощью итерационной 

уточняющей модели, описывающей углы ориентации спутника и камеры. 

1. Откройте данные I1.tif с автоматическим определением проекции и разрешения 

(см. «Открытие изображения с автоматическим определением проекции и 

разрешения»). Визуализируйте изображение в режиме RGB–модели (см. «Работа с 

гистограммой изображения»).  

2. При наличии данных GTOPO-30 и SRTM-90, загрузите модель SRTM-90 -на 

территорию изображения с исправлением ошибок ЦМР с помощью модели 

GTOPO-30 и метода многоуровневых кубических сплайнов (см. «Пакетная 
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загрузка данных GTOPO-30 и SRTM-90»). При отсутствии данных GTOPO-30 и 

SRTM-90 откройте изображение DEM1.grd, при загрузке которого в диалоге 

Open в закладке Project Settings поставьте автоматическое определение проекции 

и разрешения и в закладке Add Images включите опцию ESRI World (см. 

«Открытие изображения с автоматическим определением проекции и 

разрешения»).  

3. Необходимо предварительно установить опорные точки, по которым будет 

производиться ортокоррекция изображения. Опорные точки были набраны в 

упражнении «Установка опорных точек», если оно было выполнено, то загрузите 

командой File->Load GCP файл Spot.tic  

Если точки GCP не отображаются, удостоверьтесь, что опция Options->Show GCP 

включена. Действие данной команды распространяется на все открытые рабочие 

окна. 

4. После загрузки опорных точек выполните команду меню Transformation->Satellite 

Orbital Modeling. В результате в активное рабочее окно будет загружена панель 

инструментов Satellite Orbital Modeling итерационной уточняющей модели. 

5. В панели инструментов Satellite Orbital Modeling в группе Channel задайте любой 

канал I1.tif и включите опцию Glue, чтобы активизировать режим коррекции для 

всех каналов данного изображения.  

Опция Glue работает для каналов, загруженных из одного файла по единым 

параметрам. 

6. В группе DEM указывается канал цифровой модели рельефа «_multilevelrelief» 

или «DEM1», который будет использоваться при ортокоррекции (в случае, если 

ЦМР не указан, высотные поправки учитываться не будут).  

7. Активизируйте все параметры, входящие в группы Satellite Position и Camera 

Model. В каждом поле появится информация телеметрии об углах ориентации 

спутника и камеры, считанная из файла снимка. Углы ориентации Satellite 

Position и Camera Model задаются в трех измерениях ROLL, PITCH и YAW.  

8. В данном случае ортокоррекция будет производиться автоматически при условии 

наличия:  

• опорных точек.  

• ЦМР местности.  
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Для автоматического подбора параметров с минимальными ошибками итерационной 

уточняющей модели нажмите кнопку Adjust. 

При коррекции в интерактивном режиме необходимо включить требуемый параметр 

в группе Satellite Position или Camera Model, установив напротив него флаг. Затем 

либо элементом управления (движок), либо вручную внести исправленное значение в 

редактируемую строку параметра. После корректировки необходимо нажать кнопку 

Apply для подтверждения внесенных изменений. 

9. После расчета модели, появляется сообщение об 

ошибке произведенной трансформации RMSE. В 

данном случае будет считаться приемлемой ошибка 

до 45 метров. В случае, если ошибка RMSE 

превышает допустимый предел, который 

определяется пространственным разрешением исходного снимка и шагом ячейки 

ЦМР, тогда необходимо отменить произведенную геометрическую коррекцию 

кнопкой Reset на панели инструментов Satellite Orbital Modeling и проверить 

точность нанесения опорных точек в предыдущем упражнении.  

10. Если требуемая точность коррекции оптимальна для данного снимка, то для 

окончательного сохранения проведенных преобразований нажмите на кнопку 

Save. При этом отменить сохраненные изменения можно только при повторном 

открытии данных в программе.  

2.7.3. Полиномиальная трансформация. 

Данный вид преобразований может быть использован в случае отсутствия 

информации о положении и углах ориентации спутника и камеры, а так же в случае 

проведения дополнительной коррекции данных прошедших предварительные этапы 

геометрической коррекции и в случае невозможности использования итерационной 

уточняющей модели. 

При полиномиальной трансформации можно использовать несколько моделей 

аппроксимации:  

 Rigid, Rotation – простой перенос и поворот без изменения масштаба пикселей 

по осям,  

 Polynomial – классическое полиномиальное преобразование до 5-ой степени,  
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 Rational Polynomial – рациональное полиномиальное преобразование до 5-ой 

степени,  

 Simple Polynomial – упрощенное полиномиальное преобразование до 5-ой 

степени.  

Для проведения полиномиальной трансформации необходимо предварительно 

установить опорные точки. 

1. Загрузите снимок с автоматическим определением проекции и разрешения.  

2. Настройте изображение в диалоге View Setting, открывается который пунктом 

меню Display->View Settings.  

3. Откройте файл с опорными точками командой меню File->Load GCP  

Для отображения точек GCP необходимо удостовериться, что опция Options->Show 

GCP включена. Действие команды распространяется на все открытые рабочие окна.  

4. Чтобы произвести полиномиальную ортокоррекцию, загрузите ЦМР территории, 

открыв файл DEM.grd с учетом наличия дополнительных файлов привязки 

5. Вызовите диалог Polynomial Transformation пунктом меню Polynomial 

Transformation->Transformation или кнопкой  на панели инструментов. 

 
Рис.16. Диалог Polynomial Transformation 
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6. В диалоге Polynomial Transformation в списке Available Channels выделите 

курсором три канала изображения снимка, которые будут трансформироваться. 

7. В группе Transformation Model задайте модель трансформации Projective 

(упрощенная рациональная полиномиальная модель первой степени).  

При использовании любой модели трансформации требуется минимальное 

количество точек. В данном случае не менее семи опорных точек.  

При этом нужно учитывать, что точность произведенной трансформации 

оценивается по значению ошибки в пределах опорной точки, точность между 

ними зависит от выбора аппроксимирующей функции и количества опорных 

точек. Для лучшего результата опорные точки должны быть нанесены 

равномерно: в центре и по краям снимка. 

8. Для проведения ортокоррекции в группе DEM Channel укажите канал «_DEM», 

содержащий матрицу высот территории.  

9. Включите флаг Only Calculate Model, чтобы оценить ошибку геометрической 

трансформации без получения окончательного результата. Нажмите кнопку Apply. 

После расчета предварительной модели появится окно Message с ошибкой RMSE 

трансформации. В данном упражнении она не превышает допустимого предела, 

которое определяется пространственным разрешением исходного снимка и шагом 

ячейки цифровой модели местности.  

10. Отключите опцию Only Calculate Model и окончательно рассчитайте модель 

трансформации, нажав на кнопку Apply. Кнопка Close закрывает диалог без 

сохранения внесенных изменений последнюю трансформацию изображения кнопкой 

  на главной панели инструментов. 

Кнопкой Reset All Transformations в диалоге Polynomial Transformation можно 

восстановить исходный вид изображения до преобразований, или можно отменить. 

11. Удалите все использованные опорные точки командой меню Transformation-

>Delete All GCP. 

2.7.4. Локальная трансформация. 

Данная модель трансформации может быть использована для исправления локальных 

ошибок, например, проведение дополнительной геометрической коррекции горных 

вершин и пиков изображения. 
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1. Используйте результат выполнения упражнения «Полимиальная трансформация» 

изображение I1.tif с автоматическим определением проекции и разрешения (см. 

«Открытие изображения с автоматическим определением проекции и 

разрешения»). Настройте изображение (см. «Визуализация изображений. 

Инструменты навигации в рабочем окне программы», «Работа с гистограммой 

изображения»).  

2. Если он существует, то загрузите файл с опорными точками через команду меню 

File->Load GCP, либо проставьте точки вручную.  

Для отображения точек GCP необходимо удостовериться, что опция Options-

>Show GCP включена. Действие данной команды распространяется на все 

открытые рабочие окна. 

3. Вызовите диалог Local Transformation командой меню Transformation->Local 

Transformation 

При локальной трансформации изображения изменяется только та часть 

изображения, которая попадает в зону влияния опорной точки. Для управления 

зоной влияния опорной точки используется два параметра в группе 

Transformation Model диалога Local Transformation: Base Grid Level, размер 

ячейки базовой сетки, и Count of Levels, количество дочерних ячеек в одной 

ячейке базовой сетки. При этом действие опорной точки, попавшей в ячейку 

базовой сетки, распространяется на все пиксели изображения этой ячейки. 

4. В диалоге Local Transformation в списке Available Channels выделите курсором 

все три канала изображения, в группе Transformation Model в поле Base Grid 

Level и в поле Count of Levels поставьте число 2.  

5. В группе Transformation Model в выпадающем списке Basis Functions задается 

аппроксимирующая функция локальной трансформации, выберите функцию 

многоуровневых кубических сплайнов Cubic B- Splines. При выборе Cubic B-

Splines коэффициенты локальной трансформации будут рассчитываться в узлах 

сетки. Кнопкой Apply запустите расчетный процесс трансформации, после его 

окончания кнопкой Close закройте диалог. 

Отменить трансформацию можно двумя способами: вернуться на шаг назад, для 

чего следует выполнить команду меню Transformation->Undo Last Transform 

или нажать на кнопку   панели инструментов, или отменить всю выполненную 
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в проекте трансформацию командой меню Transformation->Undo All 

Transformations. 

6. Удалите все использованные опорные точки Transformation->Delete All GCP. 

2.7.5. Автоматическая ко-регистрация изображений. 

Ко-регистрация – это автоматическое совмещение двух или более растровых 

изображений, одно из которых выбирается в качестве эталонного. При 

автоматической ко-регистрации опорные точки, связывающие эталонный и 

обрабатываемый растры, определяются методом корреляции растровых изображений. 

В программе реализован метод иерархической корреляции растровых изображений, 

позволяющий выполнять поиск опорных точек с суб-пиксельной точностью для 

изображений различного пространственного разрешения.  

1. Откройте два снимка съемочной системы IRS на одну и ту же территорию I1.tif и 

I2.tif с автоматическим определением проекции и разрешения (см. «Открытие 

изображения с автоматическим определением проекции и разрешения»).  

2. Настройте изображение в диалоге View Setting в режиме модели RGB, где в 

соответствующих слотах поставьте по порядку каналы:  

• В слоте RED - I1_ch1; • В слоте Green – I1_ch2; • В слоте Blue – I2_ch1; 

Данный вид отображения 2 снимков позволит оценить степень их пространственного 

совмещения.   

3. Для проведения автоматической ко-регистрации изображений вызовите диалог 

Image Co-Registration, выполнив команду меню Transformation->Co-

Registration или нажав на кнопку панели инструментов (рис.17).  

 
Рис. 17. Задание параметров автоматической ко-регистрации изображений I1.tif и 

I2.tif в диалоге Image Co-Registration  
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4. В диалоге Image Co-Registration в группе Reference Image укажите эталонный 

канал «I1_ch1», к которому будет производиться привязка. В группе Floating 

Image задайте привязываемый канал «I2_ch1» с отключенной опцией Glue. 

В случае привязки многоканального изображения в группе Floating Image 

выбирается любой из его каналов, приэтом активируется опция Glue, чтобы 

автоматически совместить все каналы привязываемого изображения и эталона.  

5. Площадь привязки указывается в группе Mask. В данном упражнении ко-

регистрация производится в пределах всего загруженного растра, поэтому 

выбирается значение none.  

6. Группа Searching Parameters отвечает за параметры автоматического поиска 

опорных точек, которые задаются в размерности Reference Image (эталонного 

изображения). Это определяет взаимосвязанный подбор числовых значений 

параметров с учетом разницы разрешений привязываемых изображений и их 

пространственного совмещения. Укажите следующие величины в полях:  

• Range (радиус поиска)- 20 пикселей,  

• Window Size (размер стороны локального окна поиска опорных точек)- 60 

пикселей, 

• Scale Level (степень двойки, определяющее число масштабных пирамид 

корреляции при поиске опорных точек) - 3, 

• Step (шаг сдвига локального окна при поиске опорных точек) - 1 пиксель, 

• Max. GCP`s (максимально возможное количество опорных точек, найденных 

на изображениях) – 1000. 

7. В группе Transformation Model задайте тип геометрического преобразования ко-

регистрации Rigid (простой перенос без изменения масштаба пикселей).  

8. В списке Operation List принимаются к исполнению правила поиска опорных 

точек и совмещения изображений, сформированные выбранными элементами 

управления в диалоге Image Co-Registration. Нажмите кнопку Insert, чтобы 

внести заданные выше параметры в операционный лист в виде строки-выражения. 

 Также вывод и замена параметров выражений в списке Operation List 

производится через кнопки Append, добавляет новую строку перед выделенной, 

Replace, изменяет выделенную строку, Remove/Copy, удаляет/копирует строку 

параметров из операционного листа в соответствующие элементы управления 
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диалога. Сохранение или открытие операционного листа осуществляется 

кнопками Load и Save. Можно пошагово провести процедуру ко-регистрации, 

выделив соотвествующую строку и нажав на кнопку Step. 

9. Выделите получившееся выражение курсором и нажмите на кнопку Set GCP`s. В 

результате отобразятся найденные в автоматическом режиме опорные точки 

изображений (рис.18). 

 Для отображения точек GCP необходимо удостовериться, что опция Options-

>Show GCP включена. Действие данной команды распространяется на все 

открытые рабочие окна. 

 
Рис. 18. Найденные в автоматическом режиме опорные точки изображений 

посредством диалога Image Co-Registration 
 

10. Нажмите кнопку Register для получения окончательного результата операции ко-

регистрации. 

 Отменить трансформацию можно двумя способами: вернуться на шаг назад, для 

чего следует выполнить команду меню Transformation->Undo Last Transform 

или нажать на кнопку  панели инструментов, или отменить всю выполненную в 

проекте трансформацию командой меню Transformation->Undo All 

Transformations. 
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2.8. Мозаика изображений. 

Мозаика – это сшивка двух или более изображений в единое растровое покрытие. 

Мозаики можно условно разделить на два типа:  

• запечатывание участков одного изображения другим  

• создание единого покрытия из двух и более соседних изображений 

2.8.1. Мозаика снимков из одного пролета. 

1. Загрузите в программу 2 снимка I1.tif и I2.tif с автоматическим определением 

проекции и разрешения (см. «Открытие изображения с автоматическим 

определением проекции и разрешения»). 

2.  Чтобы оценить степень 

пространственного совмещения двух 

снимков из одного пролета, откройте 

диалог View Settings, вызываемый 

командой меню Display->View Settings 

или кнопкой  на панели 

инструментов. В закладке Adjust Layers 

в группе New Layer, в слотах 

Red:Green:Blue добавьте комбинацию 

каналов R:G:B второго снимка (рис.19). 

   Добавление выбранной комбинации 

каналов в список группы Layers 

происходит кнопкой Add. 

Кнопки группы Layers:  

• Переключение и перемещение между 

RGB – слоями снимков осуществляется 

с помощью кнопок- Up или Down. 

Активизированный слой каналов 

подсвечен.  

Рис. 19. Диалог View Settings, закладка 

Adjust Layers 

• Кнопка Visibility позволяет сделать выделенный слой каналов невидимым.  

•  В закладке Adjust Colors, в слотах Red:Green:Blue выводятся те каналы снимка, 

слой которых выделен в Adjust Layers. 
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3. Если изображения не совмещены относительно друг друга, то требуется их 

геометрическая коррекция («Геометрическая коррекция»). 

В случае 2-х смежных снимков из одного пролета следует воспользоваться 

автоматической ко-регистрацией через команду Transformation->Co-Registration 

или быструю кнопку ). 

4. Для создания мозаики надо вызвать диалог Combine Channels через меню Edit-

>Macro->Custom (рис.20). 

В диалоге реализована возможность осуществлять алгебру изображений, выбирать 

математические операции, комбинирующие значения пикселов зональных 

снимков. 

 
Рис.20. Задание макроса Stack two Channels в диалоге Combine Channels 

При открытии диалога по умолчанию в поле шаблонов обработки Templates выбран 

макрос создание мозаики снимков из одного пролета - Utility\ Stack two Channels.  

• Так как используется шаблон обработки, то в группе Inputs Selection заданы 

имена переменных (Layer1 и Layer2), которым необходимо присвоить растровые 

слои из раскрывающегося списка напротив.  

• Для правильной работы макроса в группе Inputs Selection при выборе переменных 

Layer1 и Layer2 укажите два одинаковых спектральных канала двух снимков для 

получения общего спектрального канала мозаики. Через кнопки     

(перемещение или удаление выделенных строк), все заданные переменные 

перенесите в список группы Inputs.  
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• Имя результирующего монохромного канала задайте в поле Output 

• В группе Combining Rule уже задано вычисляемое выражение. Это 

арифметическое выражение, записанное с использованием переменных, а также 

констант, предопределенных функций и переменных. 

• В Resampling Filter выберите любой ресемплирующий фильтр. 

• Выбрать площадь обработки изображения можно либо в группе Vector Mask, 

задав соответствующий векторный слой и предварительно убрав галочку 

напротив опции Raw Data в группе Options, либо в группе Domain. В данном 

случае только в группе Domain , общую-Union. 

• Списки Functions и Names позволяют выбрать и вставить в выражение функции, 

в данном случае ничего не выбирайте. Параметры в группе Options должны быть 

не активны. 

Кнопкой OK выполните расчет одного канала мозаики, затем повторите 

последовательно операцию задания второго и третьего канала мозаики через диалог 

Combine Channels, не забывая присваивать переменным Layer1 и Layer2 в группе 

Inputs Selection правильные спектральные каналы двух изображений.  

2.8.2. Общая мозаика снимков. 

1. Откройте два снимка съемочной системы Spot4: Fr1/I1.tif и Fr1/I2.tif или 

Fr1/M1.tif и Fr2/M1.tif.  

2. Для оценки перекрытия снимков, визуализируйте их одновременно в диалоге 

View Settings, вызываемый через главное меню программы Display->View 

Settings или быстрой кнопкой  на панели инструментов.  

В закладке Adjust Layers диалога View Settings добавьте комбинацию каналов R:G:B 

второго снимка (рис.21). 

Добавление происходит кнопкой Add той комбинации каналов, которая 

установлена в группе New Layer, в слотах R:G:B.  

Переключение и перемещение между RGB - моделями осуществляется с 

помощью кнопок Up и Down. Кнопка Visibility позволяет сделать выделенный слой 

каналов невидимым. В закладке Adjust Colors выводятся те каналы, слой которых 

активен в Adjust Layers.  
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3.  Выберите в качестве референцного изображения снимок I1 и настройте параметры 

его визуализации. 

4.  Сохраните исходную палитру или параметры визуализации в формате Color 

Properties Data Files с расширением *.dat кнопкой Save в закладке Adjust Colors 

диалога View Settings. 

5. Проведите автоматическую тональную 

балансировку изображений. Для этого 

выполните команду Edit->Spectral 

Enhancement->Color-balance Control 

главного меню программы. В открывшемся 

диалоге Color-balance Control, переключая в 

группе RGB Slot цветовые слоты поканально, 

для каждого слота выберете опорное 

(Reference) и настраиваемое (Tuned) 

изображение в группе Available Channels. В 

зоне перекрытия двух изображений 

инструментом Select Region выберете 

тестовый участок и нажмите кнопку Add Stat 

в диалоге Color-balance Control. После этого 

будет выполнена автоматическая тональная 

балансировка настраиваемого изображения к 

опорному. 

 Рис. 21. Диалог View Settings, 

закладка Adjust Layers 

6. Чтобы улучшить качество полученного результата в группе Histogram Range с 

помощью движков задайте корректируемый яркостной диапазон, а затем 

движками, расположенными снизу и справа окошка визуализации диалога Color-

balance Control, установите красную линию параллельно осевой линии 

гистограммы корелляции для каждого слота в группе RGB Slot. 

7. Создайте новый векторный слой через команду Vector->Vector Editor (см. 

упражнение «Создание нового векторного слоя»), например «mask.mif», сделайте 

его редактируемым и отрисуйте полигональную область границы сшивки. Задайте 

стиль отображения векторного объекта в диалоге Symbology, вызываемый 

нажатием на кнопку Legend в диалоге Vector Layers Control, с прозрачной 
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областью и границей красного 

цвета (см. упражнение 

«Определение стиля отображения 

объектов в векторном слое») 

8. В меню Display->View Settings-

>Adjust Layers выделите рабочее 

изображение и в раскрывающемся 

списке Vector выберете 

соответствующую ему векторную 

маску «mask.mif» (или Select 

Region), нажмите на кнопку 

Apply. Рабочее изображение будет вырезано по контуру векторной маски. 
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4.  ПОРЯДОК  ВЫПОЛНЕНИЯ  ЛАБОРАТОРНОЙ  РАБОТЫ 

4.1. Исходные данные 

 Космические снимки с космического аппарата Spot в мультиспектральном и 

панхроматическом разрешениях – исходные данные предоставляется 

преподавателем;  

 Орбитальные данные для привязки снимков – файлы расписаний и орбитальные 

данные предоставляется преподавателем;  

 Векторные слои для привязки изображений (Дорожная_сеть-Дорожная_сеть.mid) – 

векторные карты предоставляется преподавателем; 

 Параметры настойки программного обеспечения.  

4.2. Общий план выполнения работы 

1. Изучить описание программного обеспечения. 

2. Изучить правила настройки ПО. 

3. Выполнить поэтапно все упражнения из раздела 6 (Варианты). 

4. После выполнения каждого упражнения сохранить копию экрана 

(alt+printScrn). 

5. Составить отчет о выполненной работе. 

6. Сдать отчет преподавателю, получить зачет по работе. 

http://www.scanex.ru/
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4.3. Содержание отчета  

Отчет по работе должен содержать:  

 Набор изображений экрана, соответствующих каждому из упражнений. 

 Описание параметров преобразований. 

 Списки точек привязки. 

 

5. КОНТРОЛЬНЫЕ ВОПРОСЫ 

1. Использование проекции. 

2. Автоматическое определение разрешения. 

3. Коррекция по гистограмме. 

4. Определение стиля отображения объектов в векторном слое. 

5. Технология привязки изображения к изображению. 

6. Создание голубого  цвета. 

7. Построение мозаик.  

8. Повышение разрешения.  

9. Опорные точки. 

10. Итерационная уточняющая модель. 

11. Полиномиальная трансформация. 

12. Локальная трансформация. 

13. Технологии привязки изображений.  

14. Ко-регистрация изображений. 
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6. ВАРИАНТЫ ЗАДАНИЙ  

 

Все студенты выполняют поэтапно упражнения с набором изображений, 

предоставленным преподавателем. 

1.1. Этапы выполнения работы 

 

Работа с данными КА Spot. Пространственное разрешение 10 и 20м. 

Исходные данные: 

I1.tif, I2.tif – мультиспектральные данные с разрешением 20м, прошедшие 

геолокацию и калибровку (см рис. 22). 

M1.tif, M2.tif – панхроматические данные с разрешением 20м, прошедшие 

геолокацию и калибровку (см рис. 22). 

Задание: 

 Установить галочки для автоматического определения проекции и разрешения; 

 Загрузить Fr1\M1.tif.; 

 Убедиться что выставилась проекция Гаусса-Крюгера, зона 9, датум Пулково, 

эллипсоид Крассовского, разрешение 20м; 

 Загрузить Fr1\I1.tif; 

 Создать RGB-окно и выбрать в качестве R:ch1, G:ch2, B:ch3 из I1.tif. (В 

загруженном изображении ch1=NIR, ch2=RED, ch3=green+yellow); 

 Загрузить R:ch1 (из M1), G:ch2 (из I1), B:ch2 (из I1). Убедиться что каналы I1 

сдвинуты относительно M1; 

 Притянуть каналы I1 (все) к M1 с помощью корегистрации (можно 

использовать файл liss2pan.reg); 

 Выполнить повышение разрешения каналов изображения I1 с помощью 

проедуры Image Fusion (подобрать такие параметры PCA и вейвлетов, чтобы и 

разрешение повышалось, и цветность сохранялась); 

 Выполнить синтез натуральных цветов из каналов после повышения 

разрешения с помощью процедуры Natural Colors2; 

 Визуализировать R:красный канал после фьюжена, G: синтезированный 

зеленый B: синтезированный синий; 
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 Загрузить векторный слой дорог (Дорожная_сеть-Дорожная_сеть.mid); 

 Выполнить проставления опорных точек по всему изображению (на 

перекрестках); 

 Выполнить трансформацию изображения (каналов, участвующих в построении 

изображения в натуральных цветах) с использованием опорных точек 

инструментом Polinomial Transformation. (Вид трансформации подобрать, 

чтобы ошибка была меньше разрешения изображения. Возможно удалить или 

отредактировать некоторые опорные точки); 

 Выполнить все вышеописанные действия для изображений из папки Fr2. 

 Загрузить оба фрагмента в 1-м окне (использовать закладку Adjust Layers окна 

View Settings); 

 Открыть Vector Layers Control, создать новый Mif-Mid. Загрузить его в список 

векторных слоев и сделать редактируемым; 

 Отрисовать контур одного из изображений мозаики, ведя контур по 

естественным границам на снимке. Сохранить изменения этого векторного 

слоя; 

 Указать этот контур в качестве границы видимости на закладке Adjust Layers; 

 Настроить параметры отображения кусков мозаики так, чтобы они смотрелись 

одним изображением. 
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Рис. 22. Изображения с КА Spot-4. 
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